Bug 981914 - After upgrade, old $releasever
After upgrade, old $releasever
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 20:17 EDT by Thiago Macedo
Modified: 2013-07-07 11:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 11:45:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thiago Macedo 2013-07-06 20:17:23 EDT
After upgrading from 17 to 19 with fedup (which seemed successfull)
But I'm with problem on some packages that needed to be reinstalled to work and now I discovered the worst problem:

The repositories are getting wrong $releasever variable and so not able to bring recent packages.

-------------------------------

[21:10] root@thiago-dell thiago # yum repolist
Loaded plugins: langpacks, priorities, refresh-packagekit
28 packages excluded due to repository priority protections
repo id                                                     repo name                                                                        status
Dropbox/17                                                  Dropbox Repository                                                                     2+2
adobe-linux-i386                                            Adobe Systems Incorporated                                                              17
fedora/17/i386                                              Fedora 17 - i386                                                                 21,720+18
fedora-chromium-stable/17/i386                              Builds of the "stable" tag of the Chromium Web Browser                                  17
google-chrome                                               Google Chrome                                                                            3
insync                                                      insync repo                                                                           10+4
korora                                                      Korora 17 - i386                                                                       112
kororaa                                                     Kororaa 17 - i386                                                                      112
rpmfusion-free/17/i386                                      RPM Fusion for Fedora 17 - Free                                                        369
rpmfusion-free-updates/17/i386                              RPM Fusion for Fedora 17 - Free - Updates                                            1,501
rpmfusion-nonfree/17/i386                                   RPM Fusion for Fedora 17 - Nonfree                                                     154
rpmfusion-nonfree-updates/17/i386                           RPM Fusion for Fedora 17 - Nonfree - Updates                                         1,380
sflphone/17/i386                                            sflphone                                                                                 3
sublime2/17/i386                                            Sublime2                                                                                 1
updates/17/i386                                             Fedora 17 - i386 - Updates                                                       10,583+10
virtualbox/17/i386                                          VirtualBox                                                                              15
repolist: 35,999


------------------------------------------------------

[21:13] root@thiago-dell thiago # cat /etc/os-release
NAME=Korora
VERSION="19 (Bruce)"
ID=korora
VERSION_ID=19
PRETTY_NAME="Korora 19 (Bruce)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:kororaproject:korora:19"


Steps to Reproduce:
1. upgrade to 19 with fedup
2. reinstalled chrome to work
3. tried to run an mp3 and discover that gstreamer is from 17!!

Actual results:
Some packages are un-upgraded? I don't know!

Expected results:

Full upgrade and configuration

Additional info:

Tell me what you need. Thanks!
Comment 1 Thiago Macedo 2013-07-06 20:21:16 EDT
FEDORA-RELEASE PACKAGE

[21:20] root@thiago-dell thiago # rpm -q fedora-release
package fedora-release is not installed
[21:20] root@thiago-dell thiago # yum list fedora-release
Loaded plugins: langpacks, priorities, refresh-packagekit
28 packages excluded due to repository priority protections
Available Packages
fedora-release.noarch                                                           17-2                                                           updates
Comment 2 Gian Paolo Mureddu 2013-07-07 00:59:56 EDT
In my case, going from 18 to 19 had the fedora-release version for 18 lingering, so I had simply to remove it (with rpm -e, mind you) and then performing a yum -y update as usual. If you do not have a fedora-release you may need to go and fetch it directly from the web-based repos.
Comment 3 Thiago Macedo 2013-07-07 11:45:27 EDT
Yes, true. The problem was the same but package name was kororaa-release-17-0.2.noarch !!
Thank you

Note You need to log in before you can comment on or make changes to this bug.