Bug 981923 - pinentry-qt doesn't work / PGP plugin does not prompt for password [NEEDINFO]
pinentry-qt doesn't work / PGP plugin does not prompt for password
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pinentry (Show other bugs)
19
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 587326
  Show dependency treegraph
 
Reported: 2013-07-06 23:13 EDT by Michael L
Modified: 2015-02-04 03:03 EST (History)
7 users (show)

See Also:
Fixed In Version: claws-mail-3.11.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-04 02:57:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bugs.michael: needinfo? (sochotni)


Attachments (Terms of Use)

  None (edit)
Description Michael L 2013-07-06 23:13:27 EDT
Description of problem: PGP plugin does not prompt for password.  Selecting email gives message of "Couldn't decrypt:  Bad passphrase".


Version-Release number of selected component (if applicable):
Version     : 3.9.2
Release     : 1.fc19


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: 
Affects both inline an MIME messages.  Worked fine under Fedora 18 prior to clean install of F19.
Comment 1 Michael Schwendt 2013-07-07 10:29:23 EDT
Works for me.

Could you do a bit of trouble-shooting, please?

Run "claws-mail --debug" in a terminal. Does that print anything relevant about your problem?

What are your GPG Preferences in Claws Mail?

Which desktop environment do you use?
Comment 2 Andreas Bierfert 2013-07-08 10:33:39 EDT
Works for me as well.

Which pinentry-gui package do you have installed? (rpm -qa pinentry*)
Comment 3 Michael L 2013-07-08 12:28:21 EDT
I found that pinentry-gtk was not installed.  Once it was, it worked fine.  Can this be added as a dependency?
Comment 4 Michael Schwendt 2013-07-08 13:56:46 EDT
A dependency on the virtual  pinentry-gui  capability is used:

  # rpm -e pinentry-gtk --test
  error: Failed dependencies:
  	pinentry-gui is needed by (installed) seahorse-3.8.2-1.fc19.x86_64
  	pinentry-gui is needed by (installed) claws-mail-plugins-pgp-3.9.2-1.fc19.x86_64


The issue is reproducible when only pinentry-qt is installed.
Comment 5 Michael Schwendt 2013-07-08 14:42:13 EDT
A strict dep on pinentry-gtk seems the way to go, unless somebody knows how to make pinentry-qt work.
Comment 6 Rex Dieter 2013-07-08 14:51:52 EDT
Does your ~/.gnupg/gpg-agent.conf contain any entry for "pinentry-program" ?
Is there anything suspect/useful logged to ~/.xsession-errors ?
Comment 7 Michael L 2013-07-08 16:04:26 EDT
No entry in  ~/.gnupg/gpg-agent.conf for a pinentry-program.

Only thing logged in ~/.xsession-errors gpg related is that gpg-agent started without ssh support.
Comment 8 Michael Schwendt 2013-07-08 16:16:38 EDT
claws-mail --debug output appears as if one had cancelled the pinentry dialog:

…
summaryview.c:3224:TIMING summary_set_ctree_from_list : 0s011ms
    message/rfc822 (offset:0 length:4173 encoding: 6)
        multipart/encrypted (offset:615 length:3558 encoding: 6)
            application/pgp-encrypted (offset:715 length:11 encoding: 6)
            application/octet-stream (offset:826 length:3285 encoding: 6)
messageview.c:1375:decrypting message part
sgpgme.c:390:tmp file /home/ms19f/.claws-mail/tmp/tmpfile.00000000
sgpgme.c:396:data 0x7fff8f6e9f18 (826 3285)
prefs_gpg.c:538:unset GPG_AGENT_INFO=/run/user/1000/keyring-nhRBpE/gpg:0:1
…
  --dialog should appear at this point--
…
sgpgme.c:436:can't decrypt (Bad passphrase)
pgpmime.c:335:plain is null!
…
Comment 9 Michael Schwendt 2013-07-08 17:07:02 EDT
Qt (QApplication) terminates early, failing to open display:

(gdb) print i
$1 = 3
(gdb) print new_argv
$2 = (char **) 0x241dbc0
(gdb) print new_argv[0]
$3 = 0x241dbf0 "/usr/bin/pinentry-qt4"
(gdb) print new_argv[1]
$4 = 0x241dc06 "-display"
(gdb) print new_argv[2]
$5 = 0x241dc0f ":3"
(gdb) print new_argv[3]
$6 = 0x0
(gdb) n
308	      i = argc;
(gdb) n
309	      app.reset (new QApplication (i, new_argv));
(gdb) n
[Inferior 1 (process 12568) exited with code 01]
Comment 10 Michael Schwendt 2013-07-09 03:30:50 EDT
pinentry-qt-0.7.6-6.el6.x86_64  is not affected.
Comment 11 Fedora Admin XMLRPC Client 2014-07-19 13:59:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora End Of Life 2015-01-09 13:43:36 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 13 Michael Schwendt 2015-01-10 07:28:56 EST
Not reproducible anymore with:

  $ rpm -q pinentry-qt
  pinentry-qt-0.8.3-7.fc21.x86_64

Expected? A known fix included?
Comment 14 Fedora Update System 2015-01-18 15:20:31 EST
claws-mail-3.11.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/claws-mail-3.11.1-3.fc20
Comment 15 Fedora Update System 2015-01-18 15:20:45 EST
claws-mail-3.11.1-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/claws-mail-3.11.1-3.fc21
Comment 16 Fedora Update System 2015-01-20 16:08:24 EST
Package claws-mail-3.11.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing claws-mail-3.11.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0957/claws-mail-3.11.1-3.fc20
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2015-02-04 02:57:45 EST
claws-mail-3.11.1-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-02-04 03:03:58 EST
claws-mail-3.11.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.