Bug 981944 - compare exits with a non-zero exit code when no error occurred
compare exits with a non-zero exit code when no error occurred
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 04:44 EDT by Tom Hughes
Modified: 2013-07-15 14:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 16:42:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2013-07-07 04:44:28 EDT
Description of problem:

In rawhide the ImageMagick compare command line tool exits with a non-zero exit code (specifically an exit code of one) even when everything worked fine.

Version-Release number of selected component (if applicable):

ImageMagick-6.8.6.3-1.fc20.x86_64

How reproducible:

Every time.

Steps to Reproduce:

rawhide [~] % compare image.jpg image.jpg /tmp/diff.jpg
rawhide [~] % echo $?
1

Actual results:

1

Expected results:

0

Additional info:

This works fine in F19 with ImageMagick 6.7.8.9.
Comment 1 Pavel Alexeev 2013-07-10 16:42:53 EDT
Thank you for the bugreport and willing make free software better.

Problem reported upstream: http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=23722
Comment 2 Pavel Alexeev 2013-07-15 14:41:49 EDT
Got upstream answer:
A perfect match for -metric ncc is 1 and not zero. If the user wants that default, then just add -metric ncc until the issue is resolved

see http://www.imagemagick.org/Usage/compare/#statistics

Note You need to log in before you can comment on or make changes to this bug.