Bug 98195 - LTC3263-[Alpha] RedHat EL 3 Alpha 3 coexisting with other Linux
LTC3263-[Alpha] RedHat EL 3 Alpha 3 coexisting with other Linux
Status: CLOSED DUPLICATE of bug 91370
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: installer (Show other bugs)
3.0
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-27 16:20 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-06-27 16:20:59 EDT
The following has be reported by IBM LTC:  
[Alpha] RedHat EL 3 Alpha 3 coexisting with other Linux 
Please fill in each of the sections below.

Hardware Environment:
6-way RS64-IV

Software Environment:
Installing RHEL 3 Alpha 3 on a machine with other Linux installed

Steps to Reproduce:
When selecting the default install methods installing RHEL 3 several problems 
arise if there is another version of linux already installed:

1) The install routine recognizes all partitions on all disks (even though the 
target install disk has been selected, and the disk containing the "other" 
linux has been de-selected).  The install routine formats the swap space of 
the "other" linux installation and uses that swap partition for itself.  An 
instance of an OS should not be stepping on another installed OS.
2) Boot loaders.  Attempting to force the RHEL install to set the boot 
partition on the target install doesn't appear to work. I can't pin this one 
down, but it appears that if the install routine detects the presence of 
another boot loader , then it ignores the flag to install GRUB
Comment 1 Jeremy Katz 2003-06-27 17:04:20 EDT
A few notes:
1) We do not support multiple Linux installations on the same machine on any
architecture.  Also, there is no support for multiple OS installation on arches
other than x86
2) Some of the boot partition handling has been improved since A4 that will help
somewhat
3) GRUB is completely irrelevant on ppc, where are you specifying grub things?

*** This bug has been marked as a duplicate of 91370 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.