Bug 98200 - gcc-2.96-113 segfaults when compiling itself with propolice patch
gcc-2.96-113 segfaults when compiling itself with propolice patch
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-27 17:32 EDT by Leonard den Ottolander
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 13:35:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard den Ottolander 2003-06-27 17:32:21 EDT
Description of problem:
When compiling gcc-2.96-113 with a self edited propolice patch it segfaults as
follows:

../../../gcc/intl/dcgettext.c:312:3: warning: function-like macro "__mempcpy"
must be used with arguments in traditional C
../../../gcc/intl/dcgettext.c: In function `dcgettext__':
../../../gcc/intl/dcgettext.c:386: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [dcgettext.o] Error 1
make[3]: Leaving directory
`/data/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux/gcc/intl'
make[2]: *** [intl.all] Error 1
make[2]: Leaving directory
`/data/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux/gcc'
make[1]: *** [bootstrap-lean] Error 2
make[1]: Leaving directory
`/data/src/redhat/BUILD/gcc-2.96-20000731/obj-i386-redhat-linux/gcc'
make: *** [bootstrap-lean] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.76524 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.76524 (%build)

 I did 5 or 6 builds on my Athlon (800MHz, 256MB, current Red Hat 7.3 system)
and it always fails at the same point. Also ran the build twice on a Pentium II
333 (Also current RH 7.3, plus 2.4.20-18.7 kernel with PaX), and it fails at the
same point at that machine as well.

Version-Release number of selected component (if applicable):
gcc-2.96-113

How reproducible:
Building this patched gcc always renders the same result. If necessary I can
provide you with the spec file and the patches, plus any other info that you
might require. (It's entirely possible the patch is not functional (yet), but
that shouldn't crash the compiler...)

Steps to Reproduce:
1.
2.
3.
    
Actual results:
gcc segfaults

Expected results:
no segfaults

Additional info:
Comment 1 Leonard den Ottolander 2003-06-28 10:03:53 EDT
Hm. I probably should not have added the protectonly.dif at first build, because
it introduces the -fno-stack-protector flag to the build of libgcc itself. Still
I don't understand why the compiler segfaults over this, instead of issueing an
error ("non existent compiler switch") and quits. Or is this expected behaviour?
Comment 2 Leonard den Ottolander 2004-03-22 13:35:57 EST
Although this is a bug (works for gcc-2.95-3) it is outside the scope
of the distribution.

As this is my own bug I assume it is ok to close WONTFIX.
Comment 3 Dan Hollis 2005-01-17 00:17:56 EST
care to share your propolice patch?
Comment 4 Leonard den Ottolander 2005-01-18 13:29:18 EST
Not sure if I still have the patch for "2.96" lying around. Not much
use anyway, as the RH modifications obviously make it useless.

I solved this problem way back then by rebuilding large parts of RHL
7.3 with gcc-2.95. The patch for that compiler can be found at
http://www.research.ibm.com/trl/projects/security/ssp/ . Only serious
issues I ran into were with some of the XFree86 video modules.

(I don't remember if I actually patched the kernel as the howto for
RHL 6.2 seems to indicate. Recently started to work on a patch for
RHEL 3 (CentOS 3) which at least builds. Have to look into the
standalone libssp to avoid having to patch glibc. Once I get some
result from this you might want to take a look at
http://www.ottolander.nl/opensource/ .)

Note You need to log in before you can comment on or make changes to this bug.