Bug 982019 - testsuite module is not independent from whole EAP build
testsuite module is not independent from whole EAP build
Status: CLOSED DUPLICATE of bug 970610
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ondřej Žižka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 15:45 EDT by Aleksandar Kostadinov
Modified: 2013-07-09 08:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 08:27:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
osgi module failure (7.30 KB, text/plain)
2013-07-07 15:45 EDT, Aleksandar Kostadinov
no flags Details
manual mode error text (17.55 KB, text/plain)
2013-07-07 16:16 EDT, Aleksandar Kostadinov
no flags Details

  None (edit)
Description Aleksandar Kostadinov 2013-07-07 15:45:56 EDT
Created attachment 770140 [details]
osgi module failure

When building the EAP 6.1.1 testsuite module independently from the whole EAP build, two components fail:
> [INFO] JBoss Application Server Test Suite: Integration - OSGi  FAILURE [5.185s]
> [INFO] JBoss Application Server Test Suite: Integration - Manual Mode Tests  FAILURE [4.020s]

These modules do not fail when run as part of full EAP build process.
Comment 1 Aleksandar Kostadinov 2013-07-07 16:16:29 EDT
Created attachment 770172 [details]
manual mode error text
Comment 2 Aleksandar Kostadinov 2013-07-08 03:46:00 EDT
I forgot to say that these failing modules should respect and use the jboss.dist system property to find EAP binaries instead of relying on the build directory.
Comment 3 Rostislav Svoboda 2013-07-09 08:27:50 EDT

*** This bug has been marked as a duplicate of bug 970610 ***

Note You need to log in before you can comment on or make changes to this bug.