Bug 98203 - ipp at 100% processor
ipp at 100% processor
Status: CLOSED DUPLICATE of bug 97958
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-27 17:54 EDT by Paul D. Mitcheson
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul D. Mitcheson 2003-06-27 17:54:37 EDT
This is the third time I have reported this bug, and each time I come to add
info to it it appears to have disappeared from bugzilla.  Very odd.  Anyway...

Description of problem:
occasionally I see a non-useful ipp process at 100% processor which slows down
my print server. It doesn't stop it working.


Version-Release number of selected component (if applicable):
cups-1.1.17-13.3


How reproducible:
will happen a couple of times per week.

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
when this is happening, output of strace -p is:

time(NULL)                              = 1056750618
recv(3, "", 2048, 0)                    = 0
time(NULL)                              = 1056750618
recv(3, "", 2048, 0)                    = 0
time(NULL)                              = 1056750618
recv(3, "", 2048, 0)                    = 0
time(NULL)                              = 1056750618
recv(3, "", 2048, 0)                    = 0
time(NULL)                              = 1056750618
recv(3, "", 2048, 0)                    = 0

and a netstat -tae gives the following.  Note the ipp process to prn1106 with
status CLOSE_WAIT.   Does this suggest a possible problem with the hp 4200 named
prn1106?

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
User       Inode
tcp        0      0 *:32768                 *:*                     LISTEN     
rpcuser    1651
tcp        0      0 localhost.localdo:32770 *:*                     LISTEN     
root       2082
tcp        0      0 *:printer               *:*                     LISTEN     
root       2081
tcp        0      0 *:netbios-ssn           *:*                     LISTEN     
root       2356
tcp        0      0 *:sunrpc                *:*                     LISTEN     
root       1591
tcp        0      0 *:http                  *:*                     LISTEN     
root       24530252
tcp        0      0 *:944                   *:*                     LISTEN     
root       1977
tcp        0      0 *:ssh                   *:*                     LISTEN     
root       24530279
tcp        0      0 *:ipp                   *:*                     LISTEN     
root       24530254
tcp        0      0 *:afs3-fileserver       *:*                     LISTEN     
root       2297
tcp        0      0 localhost.localdom:smtp *:*                     LISTEN     
root       2181
tcp        0      0 *:https                 *:*                     LISTEN     
root       24530253
tcp        0      0 capprint:netbios-ssn    cardhu:1095             ESTABLISHED
root       479262
tcp        0      0 capprint:netbios-ssn    sklib142.lib.ic.ac:2491 ESTABLISHED
root       10565113
tcp        0      0 capprint:netbios-ssn    barney:1298             ESTABLISHED
root       174551
tcp        0      0 capprint:netbios-ssn    sklib135.lib.ic.ac:4599 ESTABLISHED
root       134962
tcp        0      0 capprint:netbios-ssn    inchgower:1223          ESTABLISHED
root       458309
tcp        0      0 capprint:netbios-ssn    guilds6.me.ic.ac.u:4527 ESTABLISHED
root       24573889
tcp        0      0 capprint:netbios-ssn    kitt:1556               ESTABLISHED
root       15380659
tcp        0      0 capprint:netbios-ssn    virtual:1070            ESTABLISHED
root       24515456
tcp        0      0 capprint:netbios-ssn    guilds3.me.ic.ac.u:4047 ESTABLISHED
root       24605460
tcp        0      0 capprint:netbios-ssn    sklib224.lib.ic.ac:3212 ESTABLISHED
root       24397148
tcp        0      0 capprint:netbios-ssn    ment52.me.ic.ac.uk:4821 ESTABLISHED
root       24618150
tcp        0      0 capprint:netbios-ssn    sklib104.lib.ic.ac:1110 ESTABLISHED
root       24396014
tcp        0      0 capprint:netbios-ssn    sklib229.lib.ic.ac:4112 ESTABLISHED
root       10847371
tcp        0      0 capprint:netbios-ssn    sklib119.lib.ic.ac:1093 ESTABLISHED
root       24397132
tcp        0      0 capprint:netbios-ssn    sklib103.lib.ic.ac:4308 ESTABLISHED
root       199934
tcp        0      0 capprint:netbios-ssn    ment50.me.ic.ac.uk:1487 ESTABLISHED
root       496309
tcp        0      0 capprint:netbios-ssn    ment50.me.ic.ac.uk:1485 ESTABLISHED
root       496282
tcp        0      0 capprint:netbios-ssn    cardhu:1097             ESTABLISHED
root       479280
tcp        0      0 capprint:netbios-ssn    sklib216.lib.ic.ac:3484 ESTABLISHED
root       477523
tcp        0      0 capprint:netbios-ssn    thames.cv.ic.ac.uk:1342 ESTABLISHED
root       24635160
tcp        0      0 capprint:netbios-ssn    sklib113.lib.ic.ac:2262 ESTABLISHED
root       24405667
tcp        0      0 capprint:963            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:961            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:967            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:965            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:970            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:netbios-ssn    sklib228.lib.ic.ac:1419 ESTABLISHED
root       24568664
tcp        0      0 capprint:netbios-ssn    sklib521.lib.ic.ac:4482 ESTABLISHED
root       24624956
tcp        0      0 capprint:946            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:959            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:942            hide:32771              TIME_WAIT  
root       0
tcp        0      0 capprint:netbios-ssn    guilds6.me.ic.ac.u:2297 ESTABLISHED
root       9751
tcp        0      0 capprint:netbios-ssn    guilds3.me.ic.ac.u:4061 ESTABLISHED
root       24605500
tcp        0      0 capprint:netbios-ssn    sklib140.lib.ic.ac:2020 ESTABLISHED
root       135947
tcp        0      0 capprint:netbios-ssn    sklib519.lib.ic.ac:3145 ESTABLISHED
root       24586358
tcp        0      0 capprint:netbios-ssn    inchgower:2067          ESTABLISHED
root       24030337
tcp        0      0 capprint:ipp            rosebank:32768          ESTABLISHED
root       24612118
tcp        0      0 capprint:ipp            circuit:58733           ESTABLISHED
root       24568040
tcp        0      0 capprint:netbios-ssn    sklib436.lib.ic.ac:4881 ESTABLISHED
root       24621522
tcp        0      0 capprint:53197          virtual:microsoft-ds    ESTABLISHED
pdm97      24539525
tcp        0      0 capprint:ipp            reactive:34784          ESTABLISHED
root       24532248
tcp        0      0 capprint:netbios-ssn    virtual:1139            ESTABLISHED
root       24517220
tcp        0      0 capprint:netbios-ssn    glenmoray:3216          ESTABLISHED
root       11927
tcp        0      0 capprint:netbios-ssn    guilds5.me.ic.ac.u:1944 ESTABLISHED
root       24627380
tcp        0      0 capprint:ipp            real:34021              ESTABLISHED
root       24532249
tcp        0      0 capprint:netbios-ssn    guilds8.me.ic.ac.u:1826 ESTABLISHED
root       147001
tcp        0      0 capprint:netbios-ssn    guilds1.me.ic.ac.u:3551 ESTABLISHED
root       24576348
tcp        0      0 capprint:ssh            circuit:58775           ESTABLISHED
root       24575493
tcp        0      0 capprint:netbios-ssn    sklib228.lib.ic.ac:1721 ESTABLISHED
root       24569356
tcp        0      0 capprint:netbios-ssn    sklib112.lib.ic.ac:1831 ESTABLISHED
root       24405825
tcp        0      0 capprint:netbios-ssn    sklib109.lib.ic.ac:1596 ESTABLISHED
root       24620324
tcp        0      0 capprint:netbios-ssn    sklib135.lib.ic.ac:3666 ESTABLISHED
root       24625340
tcp        0      0 capprint:netbios-ssn    sklib520.lib.ic.ac:3318 ESTABLISHED
root       563126
tcp        0      0 capprint:netbios-ssn    cpgsec:1097             ESTABLISHED
root       24406001
tcp        0      0 capprint:netbios-ssn    dyson:1264              ESTABLISHED
root       24576290
tcp        0      0 capprint:netbios-ssn    vinter1:1038            ESTABLISHED
root       24568571
tcp        0      0 capprint:netbios-ssn    aberlour:2072           ESTABLISHED
root       10499
tcp        0      0 capprint:netbios-ssn    coleburn:1037           ESTABLISHED
root       456144
tcp        0      0 capprint:netbios-ssn    melibnt01.lib.ic.a:1223 ESTABLISHED
root       24545417
tcp        0      0 capprint:55130          linkwood1:microsoft-ds  ESTABLISHED
nobody     24558428
tcp        0      0 capprint:netbios-ssn    edradour:4233           ESTABLISHED
root       24493695
tcp        0    144 capprint:ssh            capserver:33181         ESTABLISHED
root       24630235
tcp        0      0 capprint:netbios-ssn    anthem:1180             ESTABLISHED
root       504639
tcp        0      0 capprint:ipp            circuit:57414           ESTABLISHED
root       24530259
tcp        0      0 capprint:netbios-ssn    asif:knetd              ESTABLISHED
root       8991778
tcp        0      0 capprint:netbios-ssn    sklib129.lib.i:corbaloc ESTABLISHED
root       10045889
tcp        0      0 capprint:36432          prn1106:ipp             CLOSE_WAIT 
root       24623819
tcp        0      0 capprint:58437          anthem:microsoft-ds     ESTABLISHED
nobody     504720
tcp        0      0 capprint:netbios-ssn    sklib409.lib.ic.ac:3738 ESTABLISHED
root       13392055
tcp        0      0 capprint:37957          caplicense:6666         TIME_WAIT  
root       0
tcp        0      0 capprint:netbios-ssn    sklib516.lib.ic.ac:4325 ESTABLISHED
root       10580697
tcp        0      0 capprint:netbios-ssn    linkwood1:1440          ESTABLISHED
root       24558382
tcp        0      0 capprint:netbios-ssn    sklib138.lib.ic.ac:4233 ESTABLISHED
root       48455
tcp        0      0 capprint:netbios-ssn    edradour:1154           ESTABLISHED
root       489116
tcp        0      0 capprint:netbios-ssn    guilds1.me.ic.ac.u:1537 ESTABLISHED
root       464962
tcp        0      0 capprint:netbios-ssn    delay:1042              ESTABLISHED
root       24623521
tcp        0      0 capprint:netbios-ssn    sklib125.lib.ic.ac:2238 ESTABLISHED
root       11647087
tcp        0      0 capprint:958            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:945            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:941            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:netbios-ssn    electra:1045            ESTABLISHED
root       24618498
tcp        0      0 capprint:969            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:966            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:964            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:962            hide:sunrpc             TIME_WAIT  
root       0
tcp        0      0 capprint:960            hide:sunrpc             TIME_WAIT  
root       0
Comment 1 Tim Waugh 2003-06-28 06:48:48 EDT

*** This bug has been marked as a duplicate of 97958 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.