Bug 982031 - SWAT Is Mising in Repository
SWAT Is Mising in Repository
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 17:55 EDT by KitchM
Modified: 2013-07-08 13:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 01:18:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description KitchM 2013-07-07 17:55:16 EDT
Description of problem:Samba is installed and was supposed to include SWAT, but it is not in the system and is also unavailable from repos.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alexander Bokovoy 2013-07-08 01:18:40 EDT
SWAT is deprecated and removed upstream.
Comment 2 KitchM 2013-07-08 11:11:47 EDT
I did not know that.

What would take its place in giving the user a graphical configuration utility? 
(The Samba Server Configuration Tool 1.2.100, aka system-config-samba, is worthless at setting up the samba environment, and smb4k is little better.)

Thanks.
Comment 3 Alexander Bokovoy 2013-07-08 11:34:53 EDT
I'd suggest to raise this question upstream since it is general question. There are few attempts every year to write graphical interface as part of Google Summer of Code, they may be tried as a starting point.

Key issue upstream had with SWAT is it being web daemon running with elevated privileges and prone to all kinds of web-related attacks.
Comment 4 KitchM 2013-07-08 13:52:22 EDT
I would guess that the attacks had to do with insecure computers, since I cannot imagine that happening with mine.  Besides, it has nothing to do with the web since it only communicates with the local computer, and should not be routed anywhere else.

It seems odd that Fedora won't put it in their repository and let the user decide.

I will attempt to track down the upstream people, whoever they are, and go from there.

Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.