Bug 982055 - Settings option gnome-shell does not do anything. Errors to log file
Settings option gnome-shell does not do anything. Errors to log file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 22:41 EDT by matobinder
Modified: 2013-07-08 00:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 00:00:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matobinder 2013-07-07 22:41:31 EDT
Not sure what to call it, but when I talk about "username widget," I am referring to the widget at the top left of the screen.(its the one with the Notifications, Logout, Lock, Poweroff" It shows my Full Name

Description of problem:

When I select "Settings" from the "username widget". Nothing happens. No menu or anything.

Looking at /var/log/messages I see these errors happen directly when I select "settings"

 /etc/gdm/Xsession[2667]: JS ERROR: !!!   Exception in callback for signal: activate
 /etc/gdm/Xsession[2667]: JS ERROR: !!!     message = '"app is null"'
 /etc/gdm/Xsession[2667]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
 /etc/gdm/Xsession[2667]: JS ERROR: !!!     lineNumber = '856'
 /etc/gdm/Xsession[2667]: JS ERROR: !!!     stack = '"([object Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/userMenu.js:856
 /etc/gdm/Xsession[2667]: wrapper([object Object],[object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
 /etc/gdm/Xsession[2667]: _emit("activate",[object GObject_Union])@/usr/share/gjs-1.0/signals.js:124
 /etc/gdm/Xsession[2667]: ([object GObject_Union])@/usr/share/gnome-shell/js/ui/popupMenu.js:114
 /etc/gdm/Xsession[2667]: wrapper([object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
 /etc/gdm/Xsession[2667]: ([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/popupMenu.js:87
 /etc/gdm/Xsession[2667]: wrapper([object GObject_Object],[object GObject_Union])@/usr/share/gjs-1.0/lang.js:213
 /etc/gdm/Xsession[2667]: "'


Version-Release number of selected component (if applicable):

This using Fedora 19, yum updated as of July 7 20:00 MDT.
gnome-shell-3.8.3-3.fc19.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Login
2. On top right, click on users name
3. Then select "Settings"

Actual results:
Nothing happens, the above error message in /var/log/messages

Expected results:
I would expect a "Settings" menu to come up

Additional info:

I did create a brand new "test user account" without any custom mods, and it also happens. I did just install Fedora 19, so I haven't done much with it yet.
Comment 1 matobinder 2013-07-07 23:59:28 EDT
Ok, so never mind. Sorry, I had accidentally un-installed the control-center RPM earlier. I just added control-center and orca back in, and all is fine.

This is not a bug. User error = Me.

Sorry for submitting.
Comment 2 matobinder 2013-07-08 00:00:12 EDT
This was user error, I am closing this out...

Note You need to log in before you can comment on or make changes to this bug.