Bug 982075 - Debuginfo missing for binaries in llvm
Debuginfo missing for binaries in llvm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Včelák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 01:39 EDT by Mamoru TASAKA
Modified: 2013-12-16 18:06 EST (History)
8 users (show)

See Also:
Fixed In Version: llvm-3.3-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:47:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2013-07-08 01:39:31 EDT
Description of problem:
Many binary files generated from llvm src.rpm lacks debuginfo information.
Looking at llvm-debuginfo binary rpm, there is no /usr/lib/debug/usr/bin directory, which means that debuginfos for /usr/bin/* genererated from llvm.src are missing.


Version-Release number of selected component (if applicable):
llvm-debuginfo-3.3-0.6.rc3.fc19.i686

How reproducible:
100%

Steps to Reproduce:
1. Install llvm-debuginfo, clang, gdb
2. gdb clang
3.

Actual results:
gdb complains that no debugging info is available.

Expected results:
Debuginfo should be available

Additional info:
The following works for me.

diff --git a/llvm.spec b/llvm.spec
index f29a500..d64d9fe 100644
--- a/llvm.spec
+++ b/llvm.spec
@@ -39,7 +39,7 @@
 
 Name:           llvm
 Version:        3.3
-Release:        0.6.%{prerel}%{?dist}
+Release:        0.6.%{prerel}%{?dist}.debuginfo
 Summary:        The Low Level Virtual Machine
 
 Group:          Development/Languages
@@ -335,6 +335,7 @@ sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config
 sed -i 's|ActiveLibDir = ActivePrefix + "/lib"|ActiveLibDir = ActivePrefix + "/%{_lib}/%{name}"|g' tools/llvm-config/llvm-config.cpp
 
 make %{_smp_mflags} REQUIRES_RTTI=1 VERBOSE=1 \
+       KEEP_SYMBOLS=1 \
 %ifarch ppc
   OPTIMIZE_OPTION="%{optflags} -UPPC"
 %else
@@ -349,6 +350,7 @@ cp -p bindings/ocaml/llvm/META.llvm bindings/ocaml/llvm/Release/
 %endif
 
 make install DESTDIR=%{buildroot} \
+       KEEP_SYMBOLS=1 \
      PROJ_docsdir=/moredocs
 
 # multilib fixes

See llvm.src/Makefile.rules .
Scratch build results:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5583338
Comment 1 Mamoru TASAKA 2013-07-08 01:44:32 EDT
With the above change, size for debuginfo rpm actually changes:
306514320  7月  8 14:19 llvm-debuginfo-3.3-0.6.rc3.fc19.debuginfo.i686.rpm
117459084  6月 12 03:37 llvm-debuginfo-3.3-0.6.rc3.fc19.i686.rpm
Comment 2 Mamoru TASAKA 2013-07-17 00:04:57 EDT
By the way, the formal llvm 3.3 is released on 2013-06-17.
Comment 3 Fedora Update System 2013-11-21 17:47:36 EST
llvm-3.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/llvm-3.3-2.fc20
Comment 4 Fedora Update System 2013-11-23 22:52:14 EST
Package llvm-3.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing llvm-3.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22023/llvm-3.3-2.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-26 09:25:18 EST
llvm-3.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/llvm-3.3-2.fc19
Comment 6 Fedora Update System 2013-11-30 03:45:01 EST
llvm-3.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/llvm-3.3-3.fc19
Comment 7 Fedora Update System 2013-12-13 22:47:28 EST
llvm-3.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-16 18:06:10 EST
llvm-3.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.