Bug 982110 - Failed to build gem native extension for redmine-2.0-openshift-quickstart
Failed to build gem native extension for redmine-2.0-openshift-quickstart
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 03:33 EDT by Wei Sun
Modified: 2015-05-14 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-07-08 03:33:58 EDT
Description of problem:
Create redmine-2.0 quickstart following README.md,but failed to git push.It returns some error messages:
remote: Installing pg (0.14.0) with native extensions
remote: Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
remote:
remote: /usr/bin/ruby extconf.rb
remote: checking for pg_config... no
remote: No pg_config... trying anyway. If building fails, please try again with
remote: --with-pg-config=/path/to/pg_config
remote: checking for libpq-fe.h... no
remote: Can't find the 'libpq-fe.h header
remote: *** extconf.rb failed ***
remote: Could not create Makefile due to some reason, probably lack of
remote: necessary libraries and/or headers. Check the mkmf.log file for more
remote: details. You may need configuration options. 

remote: Gem files will remain installed in /var/lib/openshift/117238592411210199597056/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/pg-0.14.0 for inspection.
remote: Results logged to /var/lib/openshift/117238592411210199597056/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/pg-0.14.0/ext/gem_make.out
remote: An error occured while installing pg (0.14.0), and Bundler cannot continue.
remote: Make sure that `gem install pg -v '0.14.0'` succeeds before bundling.
remote: An error occurred executing 'gear postreceive' (exit code: 5)
remote: Error message: Failed to execute: 'control build' for /var/lib/openshift/117238592411210199597056/ruby
remote:
remote: For more details about the problem, try running the command again with the '--trace' option. 

Version-Release number of selected component (if applicable):
https://github.com/openshift/redmine-2.0-openshift-quickstart
devenv_3456

How reproducible:
Always

Steps to Reproduce:
1.Create redmine-2.0 quick start following :  https://github.com/openshift/redmine-2.0-openshift-quickstart
2.
3.

Actual results:
remote: Installing pg (0.14.0) with native extensions
remote: Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
remote:
remote: /usr/bin/ruby extconf.rb
remote: checking for pg_config... no
remote: No pg_config... trying anyway. If building fails, please try again with
remote: --with-pg-config=/path/to/pg_config
remote: checking for libpq-fe.h... no
remote: Can't find the 'libpq-fe.h header
remote: *** extconf.rb failed ***
remote: Could not create Makefile due to some reason, probably lack of
remote: necessary libraries and/or headers. Check the mkmf.log file for more
remote: details. You may need configuration options.
remote:
remote: Provided configuration options:
remote: --with-opt-dir
remote: --without-opt-dir
remote: --with-opt-include
remote: --without-opt-include=${opt-dir}/include
remote: --with-opt-lib
remote: --without-opt-lib=${opt-dir}/lib
remote: --with-make-prog
remote: --without-make-prog
remote: --srcdir=.
remote: --curdir
remote: --ruby=/usr/bin/ruby
remote: --with-pg
remote: --without-pg
remote: --with-pg-dir
remote: --without-pg-dir
remote: --with-pg-include
remote: --without-pg-include=${pg-dir}/include
remote: --with-pg-lib
remote: --without-pg-lib=${pg-dir}/lib
remote: --with-pg-config
remote: --without-pg-config
remote: --with-pg_config
remote: --without-pg_config
remote:
remote:
remote: Gem files will remain installed in /var/lib/openshift/117238592411210199597056/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/pg-0.14.0 for inspection.
remote: Results logged to /var/lib/openshift/117238592411210199597056/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/pg-0.14.0/ext/gem_make.out
remote: An error occured while installing pg (0.14.0), and Bundler cannot continue.
remote: Make sure that `gem install pg -v '0.14.0'` succeeds before bundling.
remote: An error occurred executing 'gear postreceive' (exit code: 5)
remote: Error message: Failed to execute: 'control build' for /var/lib/openshift/117238592411210199597056/ruby
remote:
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://117238592411210199597056@7bmrkn5npn-95i61sm5yv.dev.rhcloud.com/~/git/7bmrkn5npn.git/
3fd7ad2..5f771b1 master -> master

Expected results:
Could create redmine-2.0 successfully

Additional info:
Comment 1 Hiro Asari 2013-07-08 10:37:21 EDT
Gemfile* and config/database.yml needs to be modified.
Comment 2 Hiro Asari 2013-07-08 10:44:36 EDT
Or maybe update Redmine to a more recent version entirely. Seems the latest release has a more intelligent Gemfile. https://github.com/redmine/redmine/blob/2.3.1/Gemfile
Comment 3 Wei Sun 2013-07-12 04:20:16 EDT
Check this bug on devenv_3491,redmine-2.0 quickstart works.Can create it successfully,and can access the app.
Comment 4 Hiro Asari 2013-07-12 09:00:27 EDT
Not sure what changed, but I've also verified that redmine works.

Note You need to log in before you can comment on or make changes to this bug.