Bug 982139 - [INSTALL]: unclear error message while removing host in up state
[INSTALL]: unclear error message while removing host in up state
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Ofer Schreiber
Pavel Stehlik
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 04:56 EDT by Barak Dagan
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 03:16:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barak Dagan 2013-07-08 04:56:17 EDT
Description of problem:
[RHEVM shell (connected)]# list hosts --show-all | egrep -w 'id|status'
id                                : c7f4445e-870e-4485-a72d-32217149adb2
status-state                      : up


[RHEVM shell (connected)]# remove host c7f4445e-870e-4485-a72d-32217149adb2

error: 
status: 409
reason: Conflict
detail: var  action  remove, var  type  host, vds cannot remove vds status illegal


Version-Release number of selected component (if applicable):
is4

How reproducible:
100%

Steps to Reproduce:
1. remove host in up state
2.
3.

Actual results:


Expected results:
error: 
status: 409
reason: illegal status
detail: vds is not in maintenance state


Additional info:
Comment 1 Michael Pasternak 2013-07-08 05:16:39 EDT
this issue is caused due to misplaced AppErros file.
Comment 2 Itamar Heim 2013-08-22 05:40:10 EDT
is this still relevant?
Comment 3 Barak Dagan 2013-09-09 03:16:37 EDT
is13 - 

[RHEVM shell (connected@10.35.161.51)]# remove host 5ed5c63e-6037-477c-8350-c1dd851a9af4

error: 
status: 409
reason: Conflict
detail: Cannot remove Host. Host is operational. Please switch Host to Maintenance mode first.

Note You need to log in before you can comment on or make changes to this bug.