Bug 98215 - Value too large for defined data type
Value too large for defined data type
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
https://bugzilla.fedora.us/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-27 20:41 EDT by Michael Schwendt
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 23:13:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2003-06-27 20:41:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
"make test" of sqlite (http://www.sqlite.org/) fails in a big file "file delete
-force test.db" test due to a bug which developers say is a TCL bug in Red Hat
Linux (9):

lt-testfixture: error deleting "test.db": Value too large for defined data type
    while executing
"file delete -force test.db"
    (file "./test/tester.tcl" line 46)
    invoked from within
"source $testdir/tester.tcl"
    (file "./test/bigrow.test" line 18)
    invoked from within
"source $testfile"
    ("foreach" body line 4)
    invoked from within
"foreach testfile [lsort -dictionary [glob $testdir/*.test]] {
  set tail [file tail $testfile]
  if {[lsearch -exact $EXCLUDE $tail]>=0} continue
  so..."
    (file "./test/quick.test" line 30)
make: *** [test] Error 1


Version-Release number of selected component (if applicable):
tcl-8.3.5-88

How reproducible:
Always

Steps to Reproduce:
1. build sqlite (configure ; make)
2. make test

An sqlite src.rpm is available at above URL.


Actual Results:  Big-file test 17 fails.

Expected Results:  Big-file test 17 should not fail.
Comment 1 Jens Petersen 2003-09-18 04:25:00 EDT
Reproduced with sqlite-2.8.6-1.src.rpm.

Can you point me to or attach the comments from the sqlite developers?
Comment 2 Michael Schwendt 2003-09-18 07:40:21 EDT
Please see comments and attachment at: 
https://bugzilla.fedora.us/show_bug.cgi?id=308
Comment 3 Jens Petersen 2003-09-18 22:25:43 EDT
Ok, thanks, though the patch just uses "exec rm" rather than 
"file delete" to work around the problem.

I still not sure whether this isn't a tcl-8.3 bug.
At least I can reproduce the problem on RHL 7.3 too.
Comment 4 Michael Schwendt 2003-09-19 08:53:31 EDT
I don't understand you. Of course that patch is only a work-around, because in
the sqlite package one could not fix a bug in tcl. That's why I didn't attach it
here. The fix for the true problem is likely in tcl 8.4 (September 2002) to
8.4.4 (July 2003).
Comment 5 Jens Petersen 2004-02-26 02:04:54 EST
Any better with tcl-8.4.5 currently in FC devel?
Comment 6 Michael Schwendt 2004-02-26 05:47:43 EST
Yes, works for me with tcl-8.4.5-5.
Comment 7 Jens Petersen 2004-02-26 23:13:54 EST
Thanks, Michael.

Note You need to log in before you can comment on or make changes to this bug.