Bug 982174 - cli crashes when setting diagnostics.client-log-level is set to trace
cli crashes when setting diagnostics.client-log-level is set to trace
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ravishankar N
:
Depends On:
Blocks: 983966
  Show dependency treegraph
 
Reported: 2013-07-08 06:41 EDT by Ravishankar N
Modified: 2014-04-17 07:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 983966 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:43:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2013-07-08 06:41:50 EDT
Description of problem:
CLI crashes when diagnostics.client-log-level is incorrectly set to 'trace' instead of 'TRACE'

How reproducible:
Always

Steps to Reproduce:
1. gluster volume set <volname> diagnostics.client-log-level trace

Actual results:
segfault

Expected results: The message:
"volume set: failed: option log-level trace: 'trace' is not valid(possible options are DEBUG, WARNING, ERROR, INFO, CRITICAL, NONE, TRACE.)"
Comment 1 Anand Avati 2013-07-08 06:44:35 EDT
REVIEW: http://review.gluster.org/5298 (cli: check for null in is_server_debug_xlator()) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2013-07-11 08:53:34 EDT
REVIEW: http://review.gluster.org/5298 (cli: check for null in is_server_debug_xlator()) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Anand Avati 2013-07-12 00:59:56 EDT
REVIEW: http://review.gluster.org/5298 (cli: check for null in is_server_debug_xlator()) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2013-07-12 07:14:49 EDT
COMMIT: http://review.gluster.org/5298 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 07833f13d43a3e3532171bb2edbe068e3a7205b1
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jul 8 15:45:54 2013 +0530

    cli: check for null in is_server_debug_xlator()
    
    Command: gluster volume set <volname> diagnostics.client-log-level trace
    Expected output:
    "volume set: failed: option log-level trace: 'trace' is not valid
    (possible options are DEBUG, WARNING, ERROR, INFO, CRITICAL, NONE,
    TRACE.)"
    Current output: gluster cli receives a segmentation fault
    Fix: check for NULL before calling strstr
    
    Change-Id: If4c7a85a635849a388cf122543e12349c109643c
    BUG: 982174
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5298
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Anand Avati 2013-09-05 06:40:59 EDT
REVIEW: http://review.gluster.org/5814 (cli: check for null in is_server_debug_xlator()) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2013-09-05 11:11:33 EDT
REVIEW: http://review.gluster.org/5814 (cli: check for null in is_server_debug_xlator()) posted (#2) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 7 Anand Avati 2013-09-06 00:25:44 EDT
REVIEW: http://review.gluster.org/5814 (cli: check for null in is_server_debug_xlator()) posted (#3) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 8 Anand Avati 2013-09-06 03:41:42 EDT
REVIEW: http://review.gluster.org/5814 (cli: check for null in is_server_debug_xlator()) posted (#4) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 9 Anand Avati 2013-09-07 10:59:48 EDT
REVIEW: http://review.gluster.org/5814 (cli: check for null in is_server_debug_xlator()) posted (#5) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 10 Anand Avati 2013-09-09 20:25:38 EDT
COMMIT: http://review.gluster.org/5814 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit f7f12d1fc644e400eec58944a24c7f7b16f41530
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Jul 8 15:45:54 2013 +0530

    cli: check for null in is_server_debug_xlator()
    
    Command: gluster volume set <volname> diagnostics.client-log-level trace
    Expected output:
    "volume set: failed: option log-level trace: 'trace' is not valid
    (possible options are DEBUG, WARNING, ERROR, INFO, CRITICAL, NONE,
    TRACE.)"
    Current output: gluster cli receives a segmentation fault
    Fix: check for NULL before calling strstr
    
    Change-Id: If4c7a85a635849a388cf122543e12349c109643c
    BUG: 982174
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5298
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/5814
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Niels de Vos 2014-04-17 07:43:15 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.