Bug 982191 - "Checking if server is up" operation is blocking server boot with jdk1.6 on windows
"Checking if server is up" operation is blocking server boot with jdk1.6 on w...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Windows
unspecified Severity high
: ER3
: EAP 6.2.0
Assigned To: Thomas Hauser
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 07:09 EDT by Petr Kremensky
Modified: 2013-12-15 11:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Doc Text Cause: Consequence: Workaround (if any): Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:21:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Checking if server is up (155.38 KB, image/png)
2013-07-08 07:09 EDT, Petr Kremensky
no flags Details
Checking if server is up with feedback (106.04 KB, image/png)
2013-07-16 15:04 EDT, Jyoti Tripathi
no flags Details

  None (edit)
Description Petr Kremensky 2013-07-08 07:09:57 EDT
Created attachment 770434 [details]
Checking if server is up

Description of problem:
There is a problem with Server Launch feature with jdk1.6 on windows. I am unable to finish installation once I choose to launch server during installation. It seem like "Checking if server is up" will block the server booting. Installer will show "server failed to start" after a while with jdk1.7, but with jdk1.6 installer will stuck with "Checking if server is up" message and all I can do is to Quit installation, kill processes, delete install folder and star again. 

Version-Release number of selected component (if applicable):
EAP 6.1.1 ER2

Steps to Reproduce:
1. java -jar jboss-eap-6.1.1.ER2-installer.jar [-console]
2. On server Launch screen choose to start Domain Mode
3. Carry on with installation until Starting server screen

Actual results:
Installation will stuck with "Checking if server is up" message

Expected results:
Either server will start successfully or "server failed to start" message is shown and I am able to finish installation

Additional info:
Same with --console installation. You may not be able to reproduce this, if server will fully boot before "Checking if server is up" message (that is why I use domain to reproduce).

Picture description:
You can see, that I am stuck with "Checking if server is up" for almost 7 minutes (I must either kill process or quit installation, because installer will never go on) and there is no server-two process (1448 - HC process, 5404 - server-one process). Sever one is not fully booted (see server.log)
Comment 1 Jyoti Tripathi 2013-07-16 15:04:25 EDT
Created attachment 774449 [details]
Checking if server is up with feedback

(see attached image) This should either fix the behaviour or let us know exactly where it is freezing.
Comment 2 Petr Kremensky 2013-07-22 03:28:32 EDT
Hi Jyoti,
I am stuck in 

Checking... (1/3)

Again, no problem with jdk1.7 only with 1.6.
Comment 3 Scott Mumford 2013-08-28 23:51:24 EDT
Marking for exclusion from the 6.1.1 Release Notes document as an entry for this bug could not be completed or verified in time.
Comment 5 mark yarborough 2013-09-05 18:54:20 EDT
Missed 6.1.1, proposing for 6.2.0, cleaning up erroneous nacks from ackviewer crash earlier today.
Comment 6 Petr Kremensky 2013-09-23 06:51:34 EDT
With 6.2.0.ER1 I am stuck with:
Checking if server is ready...(1/21).
Comment 7 Thomas Hauser 2013-09-30 10:59:17 EDT
Hmm, this shouldn't be occuring. Can you paste more information? Does the Checking if server is ready task ever time out / advance? (2/21, 3/21) etc?
Comment 11 Petr Kremensky 2013-10-18 09:28:19 EDT
This was fixed by BZ1015573.

Verified on EAP 6.2.0.ER6 installer.

Note You need to log in before you can comment on or make changes to this bug.