Bug 982209 - Impossible to update google chrome to v28
Impossible to update google chrome to v28
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc (Show other bugs)
6.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 08:00 EDT by Bartosz Malkiewicz
Modified: 2013-10-17 19:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 08:42:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bartosz Malkiewicz 2013-07-08 08:00:26 EDT
Description of problem:
Latest google chrome browser (v. 28) requires glibc-3.4.15 which is not shipped for RHEL 6. In addition, google doesn't support Chrome v. 27 anymore (not available through google repository). This make it installation of new google chrome impossible on RHEL 6, update is also impossible (as version can't be updated from v27 to v28 because of missing glibc dependencies)

Version-Release number of selected component (if applicable):
Google Chrome v. 28

How reproducible:
Try to install google chrome latest version on RHEL

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Siddhesh Poyarekar 2013-07-08 08:12:34 EDT
There is no glibc 3.4.15.  Maybe you mean the kernel version 3.4.15?
Comment 3 Bartosz Malkiewicz 2013-07-08 08:29:43 EDT
-> Running transaction check
---> Package google-chrome-stable.x86_64 0:27.0.1453.93-200836 will be updated
---> Package google-chrome-stable.x86_64 0:28.0.1500.71-209842 will be an update
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: google-chrome-stable-28.0.1500.71-209842.x86_64
--> Finished Dependency Resolution
Error: Package: google-chrome-stable-28.0.1500.71-209842.x86_64 (google-chrome)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Comment 4 Siddhesh Poyarekar 2013-07-08 08:35:39 EDT
That's libstdc++, not glibc.  I don't think we can do anything about this, but I'll let the gcc maintainers close this as wontfix.
Comment 5 Jakub Jelinek 2013-07-08 08:42:10 EDT
Yeah, the only way around this would be convince google to build chrome on RHEL using Developer Toolset, then it would work.  Updating the system libstdc++.so.6 is definitely not an option.

Note You need to log in before you can comment on or make changes to this bug.