Bug 98222 - bind crash on assertion
bind crash on assertion
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-28 03:00 EDT by Nick Warne
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-30 14:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Warne 2003-06-28 03:00:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021212 K-Meleon/0.7

Description of problem:
Fully up2date Red Hat 7.1, Running kernel ->  2.4.20-18.7 - no X-windows.

Information.
============
I run just a DNS caching only server for 6 machines on local home network.

Output from rndc.
=================
[root@Linux233 rpm]# rndc status
number of zones: 4
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
server is up and running

The problem.
============

Occasionally, maybe 70 - 90 days uptime, bind will crash with this in
/var/log/messages:

Jun 26 13:04:52 Linux233 named[729]: mem.c:653: INSIST(ctx->stats[size].gets >
0) failed
Jun 26 13:04:52 Linux233 named[729]: exiting (due to assertion failure)

I cannot find a way to replicate this, as it happens so rarely and always when I
am AFK.  No core file is produced.

I filed a bug report with the ISC-Bugs people, but was recommended to update to
BIND 9.2.2 - which Red Hat does not yet have a release for.

Regards,

Nick

Version-Release number of selected component (if applicable):
BIND 9.2.1

How reproducible:
Couldn't Reproduce


Additional info:

Reply from ISC-Bugs people:

If you have a core dump then please send a stack backtrace.
 The error indicates that a block of memory is being freed
 twice or being freed with the wrong size tag,

 Upgrade.  The current release is BIND 9.2.2.
--
Mark Andrews, Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: Mark.Andrews@isc.org
Comment 1 Daniel Walsh 2003-06-30 14:53:28 EDT
bind 9.2.2 is available on rawhide.

http://rawhide.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/bind-9.2.2-15.i386.rpm
Comment 2 Nick Warne 2003-07-01 14:11:25 EDT
OK.  But there is a huge dependency trail on RH 7.1 with this.  Need the new
GLIBC libaries...

Nick

Note You need to log in before you can comment on or make changes to this bug.