Bug 982245 - vdsm is reporting negative values for available memory
vdsm is reporting negative values for available memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.2
Assigned To: ofri
Lukas Svaty
sla
: Reopened, ZStream
Depends On: 956750
Blocks: 977758 982639
  Show dependency treegraph
 
Reported: 2013-07-08 09:12 EDT by Idith Tal-Kohen
Modified: 2016-02-10 15:18 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, VDSM used the memAvailable parameter to report available memory on a host, which could return negative values if memory overcommitment was in use. Now, the new memFree parameter returns the actual amount of free memory on a host.
Story Points: ---
Clone Of: 956750
Environment:
Last Closed: 2013-08-13 09:07:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 290883 None None None Never
oVirt gerrit 15328 None None None Never
oVirt gerrit 16253 None None None Never
oVirt gerrit 16256 None None None Never

  None (edit)
Description Idith Tal-Kohen 2013-07-08 09:12:43 EDT
+++ This bug was initially created as a clone of Bug #956750 +++

Description of problem:
VDSM is reporting negative values for available memory.

Version-Release number of selected component (if applicable):
vdsm-4.10.2-15.0

How reproducible:
100%

Steps to Reproduce:
1. Run memory load on host
2. vdsClient -s 0 getVdsStats | grep memAvailable
  
Actual results:
VDSM reports negative values ( memAvailable = -818 )

Expected results:
VDSM should never report negative values for available memory

--- Additional comment from Doron Fediuck on 2013-06-03 08:04:09 EDT ---



--- Additional comment from Saveliev Peter on 2013-06-04 06:26:23 EDT ---

The current memory computation is accurate and takes into account memory overcommitment. That's why one can get negative values there even if there is no KSM running.

Maybe it should be mentioned in the docs — then open docs issue, please. But it is not a bug.

--- Additional comment from Oded Ramraz on 2013-06-05 05:29:29 EDT ---

Peter , can we show 0 instead of negative number? 
Showing negative numbers as for available memory has bad user experience / impact.

--- Additional comment from Saveliev Peter on 2013-06-05 05:45:12 EDT ---

Technically speaking, we can show anything. Yes, we can split one value into two: available memory (from 0 to N) and memory overcommitment (from -N to -1).

But since this particular value is used only in the engine, it is better to keep current behaviour:

1. users are not supposed to do anything with VDSM ←→ engine protocol
2. the engine can rely on this values

vdsClient is written to be used by experienced administrators and developers, so it is better to mention this particular case in the project documentation, 'cause it can be confusing.

--- Additional comment from Michal Skrivanek on 2013-06-05 05:58:27 EDT ---

I second the suggestion to keep showing negative values and provide an explanation in docs.

--- Additional comment from Doron Fediuck on 2013-06-10 12:00:05 EDT ---

Re-opening on the engine as this is creating false events in the system.
Additionally, the existing logic in the system should be verified in this light.

--- Additional comment from ofri on 2013-06-23 03:45:33 EDT ---

After discussion: This bug will require both change in VDSM and engine. 
VDSM currently does not report the true free memory on the host. instead it reports the total memory minus the sum of all used memory (for all processes).
VDSM should report true free mem on host. this data should be the one referenced by the engine in context of 'minimum memory' events.
Comment 3 errata-xmlrpc 2013-08-13 09:07:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1149.html

Note You need to log in before you can comment on or make changes to this bug.