Bug 98227 - /usr/X11R6/bin missing in $PATH for zsh users
/usr/X11R6/bin missing in $PATH for zsh users
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-28 05:40 EDT by Christian Rose
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-08 23:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2003-06-28 05:40:46 EDT
Description of problem:

For a user logging in via SSH and using zsh, it seems that 

  /usr/X11R6/bin

doesn't get added to the $PATH, as it is for bash users. This prevents
applications like gv or xterm from being run by zsh users.
This is the $PATH a test user got with bash:

  /usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/test/bin

And this is the one the same test user got with zsh:

  /usr/local/bin:/bin:/usr/bin:/home/test/bin


How reproducible:

Every time.


Steps to Reproduce:

1. Create two users, one with bash as the shell, and one with zsh
2. Login using SSH as the two users
3. Compare the $PATH

    
Actual results:

The $PATH for the zsh and the bash users differ; the zsh user lacks
/usr/X11R6/bin in the path


Expected results:

The $PATH for both zsh users and bash users should be the same, and include
/usr/X11R6/bin
Comment 1 Jens Petersen 2003-11-25 00:08:12 EST
I'm not able to reproduce this in a fresh FC1 install,
and there haven't been any path related changes since RHL9.

/usr/X11R6/bin is added by /etc/profile which is read by
both bash and zsh.
Comment 2 Jens Petersen 2003-12-08 23:49:30 EST
Closing for now: please re-open if you can still reproduce this.

Note You need to log in before you can comment on or make changes to this bug.