Bug 982289 - LSM process failed, snapshot created and disk didn't migrate
LSM process failed, snapshot created and disk didn't migrate
Status: CLOSED DUPLICATE of bug 985043
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Allon Mureinik
storage
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 11:19 EDT by Aharon Canan
Modified: 2016-02-10 14:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 11:01:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
spm (1.05 MB, text/plain)
2013-07-08 11:19 EDT, Aharon Canan
no flags Details
hsm (4.71 MB, text/plain)
2013-07-08 11:21 EDT, Aharon Canan
no flags Details
engine (1.05 MB, text/plain)
2013-07-08 11:27 EDT, Aharon Canan
no flags Details

  None (edit)
Description Aharon Canan 2013-07-08 11:19:57 EDT
Created attachment 770544 [details]
spm

Description of problem:
=======================
Live disk migration failed 
snapshot created although Ui reported it fails

in HSM we found - 
Thread-5319::ERROR::2013-07-08 17:31:25,663::BindingXMLRPC::954::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 940, in wrapper
    res = f(*args, **kwargs)
TypeError: vmSnapshot() takes exactly 3 arguments (4 given)

in engine - 
2013-07-08 17:31:26,606 INFO  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (pool-5-thread-46) Ending command successfully: org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand
2013-07-08 17:31:26,666 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) START, SnapshotVDSCommand(HostName = camel-vdsb, HostId = d2ec70c0-e816-470d-b90c-96a3e2d9f163, vmId=707fef33-4cef-4be1-8fcf-4b2fb78cd28f), log id: 10690dd7
2013-07-08 17:31:26,674 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) Failed in SnapshotVDS method
2013-07-08 17:31:26,674 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) Error code unexpected and error message VDSGenericException: VDSErrorException: Failed to SnapshotVDS, error = Unexpected exception
2013-07-08 17:31:26,674 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) Command org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand return value 
2013-07-08 17:31:26,674 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) HostName = camel-vdsb
2013-07-08 17:31:26,675 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) Command SnapshotVDS execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed to SnapshotVDS, error = Unexpected exception
2013-07-08 17:31:26,675 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SnapshotVDSCommand] (pool-5-thread-46) FINISH, SnapshotVDSCommand, log id: 10690dd7
2013-07-08 17:31:26,675 WARN  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (pool-5-thread-46) Wasnt able to live snpashot due to error: VdcBLLException: VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SnapshotVDS, error = Unexpected exception (Failed with VDSM error unexpected and code 16). VM will still be configured to the new created snapshot
2013-07-08 17:31:26,705 INFO  [org.ovirt.engine.core.bll.CreateSnapshotCommand] (pool-5-thread-46) [2efef305] Ending command successfully: org.ovirt.engine.core.bll.CreateSnapshotCommand


Version-Release number of selected component (if applicable):
3.3 (is4)

How reproducible:


Steps to Reproduce:
1. in iscsi storage with two hosts, create a vm from template
2. run the vm on hsm
3. start a live storage migration on the vm disk

Actual results:
LSM failed

Expected results:
should complete successfully

Additional info:
Comment 1 Aharon Canan 2013-07-08 11:21:00 EDT
Created attachment 770545 [details]
hsm
Comment 2 Aharon Canan 2013-07-08 11:27:50 EDT
Created attachment 770546 [details]
engine
Comment 4 Allon Mureinik 2013-07-24 11:01:32 EDT

*** This bug has been marked as a duplicate of bug 985043 ***

Note You need to log in before you can comment on or make changes to this bug.