Bug 982301 - Unable to assign DataObject input/output mapping.
Summary: Unable to assign DataObject input/output mapping.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER5
: 6.0.0
Assignee: Tihomir Surdilovic
QA Contact: Sona Mala
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-08 15:38 UTC by Marek Baluch
Modified: 2013-11-27 20:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-27 20:05:54 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (272.29 KB, image/png)
2013-07-08 15:38 UTC, Marek Baluch
no flags Details
screenshot with designer (50.84 KB, image/png)
2013-08-27 13:42 UTC, Tihomir Surdilovic
no flags Details
Screenshot - ER3 (29.73 KB, image/png)
2013-10-09 13:30 UTC, Sona Mala
no flags Details

Description Marek Baluch 2013-07-08 15:38:36 UTC
Created attachment 770550 [details]
screenshot

Description of problem:

When a "DataObject" is present in the process diagram it's not available in the assignments editor.

Please see attached image.

Comment 1 Tihomir Surdilovic 2013-08-27 13:41:58 UTC
I am unable to reproduce this issue. Please verify with latest.

Comment 2 Tihomir Surdilovic 2013-08-27 13:42:20 UTC
I am unable to reproduce this issue. Please verify with latest.

Comment 3 Tihomir Surdilovic 2013-08-27 13:42:54 UTC
Created attachment 790978 [details]
screenshot with designer

Comment 4 Marek Baluch 2013-08-27 13:53:09 UTC
will verify.

Comment 5 Marek Baluch 2013-08-27 16:29:41 UTC
Tiho, what definitions do you have in your DataInputSet for the "test" user task?

Comment 9 Sona Mala 2013-10-09 13:29:30 UTC
I can reproduce this for ER3. See a new attachment. Please Tiho, do you know a commit which should fix this issue?

Comment 10 Sona Mala 2013-10-09 13:30:41 UTC
Created attachment 809943 [details]
Screenshot - ER3

Comment 11 Tihomir Surdilovic 2013-11-13 21:40:52 UTC
There is no need for this. Designer automatically creates the data inputs/outputs and assignments for the user in the case a data object is connected to a task node. Users do not have to do this for themselves. Connect data object to task save and reopen the process and look at the data inputs/outputs and assignments properties of the task.

Comment 12 Marek Baluch 2013-11-27 20:05:54 UTC
Closing this as not a bug. A DataOutput mappings can indeed be created.


Note You need to log in before you can comment on or make changes to this bug.