Bug 982313 - ethtool -d on RTL8168b/8111b crashes kernel hard
ethtool -d on RTL8168b/8111b crashes kernel hard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 11:52 EDT by James
Modified: 2013-12-25 13:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 13:52:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2013-07-08 11:52:46 EDT
Description of problem:
Running ethtool -d on my notebook's Ethernet port causes the system to freeze. Magic SysRq does not work.

I have no other stackdump information to hand. No error messages appear on the console before the freeze.

Version-Release number of selected component (if applicable):
kernel-3.9.9-301.fc19.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. ethtool -d enp8s0

Actual results:
The register dump is all 0xff; the system then seems to fumble and half a second later freezes completely.

Expected results:
No crash.

Additional info:

dmesg standard info for the chip:
[   21.370839] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   21.371235] r8169 0000:08:00.0: irq 48 for MSI/MSI-X
[   21.371431] r8169 0000:08:00.0 eth0: RTL8168b/8111b at 0xffffc900103f2000, 00:90:f5:69:d5:9e, XID 18000000 IRQ 48
[   21.371435] r8169 0000:08:00.0 eth0: jumbo features [frames: 4080 bytes, tx checksumming: ko]
Comment 1 Michele Baldessari 2013-08-17 19:12:21 EDT
Hi James,

probably worth keeping an eye on this patch (not ready for net-next yet):
http://patchwork.ozlabs.org/patch/267971/

cheers,
Michele
Comment 2 Josh Boyer 2013-09-18 16:47:08 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 James 2013-09-21 03:35:31 EDT
Still happens with kernel 3.11.1-200.fc19.
Comment 4 Michele Baldessari 2013-11-26 13:12:48 EST
Hi James, 

the above patch has made it in 3.12:
commit 15edae91cb2d91131ab3b0c6eebf1fbfc12d643e
Author: Peter Wu <lekensteyn@gmail.com>
Date:   Wed Aug 21 23:17:11 2013 +0200

    r8169: fix invalid register dump
    
    For some reason, my PCIe RTL8111E onboard NIC on a GA-Z68X-UD3H-B3
    motherboard reads as FFs when reading from MMIO with a block size
    larger than 7. Therefore change to reading blocks of four bytes.
    
    Ben Hutchings noted that the buffer is large enough to hold all
    registers, so now all registers are read.
    
    Signed-off-by: Peter Wu <lekensteyn@gmail.com>
    Acked-by: Francois Romieu <romieu@fr.zoreil.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>


Could you check a 3.12 kernel and report back?
http://alt.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/x86_64/

Thanks,
Michele
Comment 5 James 2013-11-26 14:17:51 EST
kernel 3.12.1-2.fc21.x86_64 -- output from ethtool looks sensible and there is no crash now.
Comment 6 Michele Baldessari 2013-11-26 14:32:48 EST
Thanks James!

Josh, this can go in POST for when 3.12 hits Fedora
Comment 7 Josh Boyer 2013-11-26 14:51:49 EST
Indeed.  Thanks all!
Comment 8 Michele Baldessari 2013-12-25 13:52:32 EST
3.12.x has hit F19 as well through updates, so am closing this one.

Thanks for the report and testing James

regards,
Michele

Note You need to log in before you can comment on or make changes to this bug.