Bug 982332 - Evolution adds a non-existent '>' character to the word From in emails
Evolution adds a non-existent '>' character to the word From in emails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 13:33 EDT by Steevithak
Modified: 2013-07-12 11:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 06:43:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of evolution bug (185.70 KB, image/png)
2013-07-08 13:33 EDT, Steevithak
no flags Details

  None (edit)
Description Steevithak 2013-07-08 13:33:42 EDT
Created attachment 770599 [details]
screenshot of evolution bug

Description of problem:
Evolution inserts a '>' character before the word "From" if it occurs as the first word in a paragraph within an email. This has the side effect of changing the color of the entire line from black to light grey as if it were quoted. 


Version-Release number of selected component (if applicable):
evolution-3.6.4-3.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. View an email that contains the word "From" as the 1st word in a paragraph
2.
3.

Actual results:
A '>' character that doesn't exist in the sent email is inserted into the displayed email. 

Expected results:
Email should be displayed as it was sent

Additional info:
This bug has actually been in Evolution for the last few versions of Fedora, I was only just reminded to file a bug report because it happened in an email I received from Redhat's bugzilla regarding another Evolution bug. :)
Comment 1 Matthew Barnes 2013-07-08 15:37:52 EDT
You must still be using an mbox-based account.

It's common practice to prepend a greater-than sign to message body lines beginning with "From", to distinguish from mbox's ill-conceived "From_" lines which mark message boundaries.

See https://en.wikipedia.org/wiki/Mbox

Maildir, which is Evolution's preferred storage format now, doesn't share this problem.
Comment 2 Steevithak 2013-07-08 16:25:21 EDT
I have always used maildir for my own folders but Evolution has always (in the past at least) forced me to have mbox format system folders (inbox, drafts, sent, etc). However, regardless of the format used, Evolution should not alter the emails this way. I'm familiar with the need for mbox to escape "From" within it's internal storage but the UI is supposed to unescape them so the user doesn't see the '>' characters.

Regarding the change from mbox to maildir for the system folders, this is excellent news. Will the folders be upgraded automatically when the newer version of Evolution is installed or does the user need to manually perform some action to upgrade those folders? Right clicking on a folder and selecting properties doesn't provide any helpful info about the current format. (I miss the early days of Evolution when you could mix and match storage formats on a per-folder basic and easily switch from one format to another with a couple of mouse clicks!)
Comment 3 Milan Crha 2013-07-09 01:56:24 EDT
There is filled a similar bug report upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=616407

I would move this there, but before that, what is the account type you received the bugzilla email in, please? The thing is that your On This Computer folders are maildir already (see Edit->Preferences->Mail Accounts, the Type column there). Either the receiving part (aka Evolution's account) broke the email, or the message was received broken already. Hard to tell, but the upstream bug suggests that this is fixed within composer since 2.32.2.

Evolution cannot strip the added character, because it cannot distinguish whether it was added by the user or by any mailer in between the sender and the receiver. I can imagine that another user will send you quoted line which will start with "From ", and there is no difference from the added letter. The related RFC, in this case, is quite unfortunate.
Comment 4 Steevithak 2013-07-09 13:54:43 EDT
Update - new information...

According to Preferences, all folders including the inbox are Maildir. In the specific case of the email in the screen capture that exhibits the problem, the mail originated from RedHat's Bugzilla, so it should be possible to determine if the sending system is at fault in this case.

Compare the screen capture I attached to the original comment here:

https://bugzilla.redhat.com/show_bug.cgi?id=981712#c4

The original does not show the '>' character, so either Redhat's sending email server added it, or Evolution did. 

Next I performed this test: I sent myself an email from a Yahoo! mail account in which I started a paragraph with the word "From" - when I received it in Evolution it did NOT show the '>' character. This may support the idea that the sending system is at fault rather than Evolution. If that turns out to the be case, maybe this bug should filed against bugzilla rather than Evolution? :)
Comment 5 Milan Crha 2013-07-12 06:43:45 EDT
Thanks for the update. I finally got soem time to test this, and I used GMail, one other public email service and the internal server and it all works as expected, the "From " is not preppended with a greater-than character. That makes me believe that one of your servers in between is at "fault".
Comment 6 Steevithak 2013-07-12 11:33:02 EDT
Actually, as described in my previous comment, it's not my server but your server that's at fault. That is, the mail server used by Redhat for bugzilla is one of the culprits. So I agree with the notabug resolution with regard to Evolution but the problem in the Redhat mail server should probably be fixed if you know where or how to file an internal bug against it.

Note You need to log in before you can comment on or make changes to this bug.