Bug 982354 - Need an easier way to compare the Oscap scan ID
Need an easier way to compare the Oscap scan ID
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: New Feature (Show other bugs)
550
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Martin Minar
: FutureFeature
Depends On:
Blocks: sat560-misc
  Show dependency treegraph
 
Reported: 2013-07-08 14:56 EDT by DzungDo
Modified: 2016-07-03 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:26:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DzungDo 2013-07-08 14:56:33 EDT
Description of problem:
We cannot easily get the scan id (xid) on the page. Currently, if I have a long list of audit report, and I want to compare two reports I have to perform a number of steps listed below 

Version-Release number of selected component (if applicable):
Satellite 5.5

How reproducible:
Always

Steps to Reproduce:
1. Open the list of audit reports for a specific host
2. Click to open one report, then select "diff to previous"
3. Here I can see the xid, so in this case, we can compare xid 64 against xid 63
4. If we want to compare xid 64 (the latest) one of the reports that has the highest number of successes:
a) go back to the list of reports for the host
b) count from top sequentially down to the one I want, note the number and hope I done my count correctly, then
c) Audit --> XCCDF --> then enter the two scan ID and submit

Actual results:


Expected results:
Can we have another "xid" column alongside with "Xccdf Test Result"?

Additional info:
Comment 1 Šimon Lukašík 2013-08-06 03:51:56 EDT
Just a note: The scan's ID is often part of URL, thus its not hidden.

There are two improvements made:
(1) The scan's details page shows scan's ID (xid) in the table
    (systems/details/audit/XccdfDetails.do)
(2) On the page listing all scans per given system, the lines of
    the table are now selectable and there is a button called
    [ Compare Selected Scans ]. That enables user to select two
    arbitrary scans by checkboxes and compare then easily.

spacewalk.git 4510a00e7f866c209e450afb0b959d8b17057b08
spacewalk.git 8eb0228abc050c9295605260a0de16a92fdc2b7c
Comment 3 Tomas Lestach 2013-08-06 11:33:48 EDT
two more minor minor issues ...

spacewalk.git:
 9094fdbe (removing unnecessary cast)
 c566119b (removing unnecessarily nested else clause)
Comment 7 Clifford Perry 2013-10-01 17:26:01 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.