Bug 982412 - [abrt] PySolFC-2.0-8.fc19: ImagingPaletteDelete: Process /usr/bin/python2.7 was killed by signal 6 (SIGABRT)
[abrt] PySolFC-2.0-8.fc19: ImagingPaletteDelete: Process /usr/bin/python2.7 w...
Status: CLOSED DUPLICATE of bug 995783
Product: Fedora
Classification: Fedora
Component: python-pillow (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
abrt_hash:db3dac209a2aaebd4a2c58297cd...
:
Depends On: 995783 1001122
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 21:08 EDT by John Duchek
Modified: 2014-01-12 19:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 17:30:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.78 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: core_backtrace (5.05 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: dso_list (13.99 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: environ (1.31 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: maps (70.77 KB, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: open_fds (142 bytes, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-07-08 21:08 EDT, John Duchek
no flags Details

  None (edit)
Description John Duchek 2013-07-08 21:08:27 EDT
Description of problem:
I installed fedora 19 using fedup, and this program no longer worked.  I was running F18 and it ran fine.

Version-Release number of selected component:
PySolFC-2.0-8.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/PySolFC/pysol.py --sound-mod=pygame
crash_function: ImagingPaletteDelete
executable:     /usr/bin/python2.7
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jul  8 18:27:41 Dell-D630-Fedora abrt[1479]: Saved core dump of pid 1385 (/usr/bin/python2.7) to /var/tmp/abrt/ccpp-2013-07-08-18:27:39-1385 (59596800 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #5 ImagingPaletteDelete at libImaging/Palette.c:126
 #6 ImagingDelete at libImaging/Storage.c:243
 #7 _dealloc at _imaging.c:198
 #8 dict_dealloc at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:1019
 #9 instance_dealloc at /usr/src/debug/Python-2.7.5/Objects/classobject.c:681
 #10 frame_dealloc at /usr/src/debug/Python-2.7.5/Objects/frameobject.c:460
 #11 fast_function at /usr/src/debug/Python-2.7.5/Python/ceval.c:4186
 #12 call_function at /usr/src/debug/Python-2.7.5/Python/ceval.c:4119
 #13 PyEval_EvalFrameEx at /usr/src/debug/Python-2.7.5/Python/ceval.c:2740
 #14 fast_function at /usr/src/debug/Python-2.7.5/Python/ceval.c:4184
Comment 1 John Duchek 2013-07-08 21:08:30 EDT
Created attachment 770727 [details]
File: backtrace
Comment 2 John Duchek 2013-07-08 21:08:33 EDT
Created attachment 770728 [details]
File: cgroup
Comment 3 John Duchek 2013-07-08 21:08:36 EDT
Created attachment 770729 [details]
File: core_backtrace
Comment 4 John Duchek 2013-07-08 21:08:40 EDT
Created attachment 770730 [details]
File: dso_list
Comment 5 John Duchek 2013-07-08 21:08:42 EDT
Created attachment 770731 [details]
File: environ
Comment 6 John Duchek 2013-07-08 21:08:44 EDT
Created attachment 770732 [details]
File: limits
Comment 7 John Duchek 2013-07-08 21:08:47 EDT
Created attachment 770733 [details]
File: maps
Comment 8 John Duchek 2013-07-08 21:08:49 EDT
Created attachment 770734 [details]
File: open_fds
Comment 9 John Duchek 2013-07-08 21:08:51 EDT
Created attachment 770735 [details]
File: proc_pid_status
Comment 10 Fedora Admin XMLRPC Client 2013-08-05 13:35:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Richard Haakma 2013-08-14 21:01:04 EDT
Attempted to start pysolfc. It did not start. I have just used fedup to upgrade to f19. pysolfc worked well in f18.


reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/PySolFC/pysol.py --sound-mod=pygame
crash_function: ImagingPaletteDelete
executable:     /usr/bin/python2.7
kernel:         3.10.5-201.fc19.x86_64
package:        PySolFC-2.0-8.fc19
reason:         Process /usr/bin/python2.7 was killed by signal 6 (SIGABRT)
runlevel:       N 5
uid:            1000
Comment 12 Jaromír Cápík 2013-08-28 08:22:21 EDT
Hello guys.

Your issues are very probably related to the issue reported in the Bug 1001122.
The problem very probably lies in the python-pillow extension. I'm changing the component to python-pillow. Roman will very probably close one of them as duplicate.

Thanks for the report.

Regards,
Jaromir.
Comment 13 Jaromír Cápík 2013-08-28 08:26:17 EDT
Sorry, wrong bug number ... I meant Bug 995783
Comment 14 Sandro Mani 2013-08-28 17:30:06 EDT

*** This bug has been marked as a duplicate of bug 995783 ***
Comment 15 Sandro Mani 2013-08-28 17:32:04 EDT
This issue should be fixed by python-pillow-2.0.0-11.gitd1c6db8.fc19. If not, please reopen.

Note You need to log in before you can comment on or make changes to this bug.