This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 982466 - "oo-admin-ctl-gears listidle" and "oo-idler-stats" can not detect idled gears
"oo-admin-ctl-gears listidle" and "oo-idler-stats" can not detect idled gears
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 02:45 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:22:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-07-09 02:45:31 EDT
Description of problem:
After idling gears by "oo-admin-ctl-gears idlegear <UUID>", "oo-admin-ctl-gears listidle" and "oo-idler-stats" can not detect idled gears

Version-Release number of selected component (if applicable):
devenv_3463

How reproducible:
always

Steps to Reproduce:
1. Create an app 
rhc app create cphp03 php-5.3 --no-git
2. SSH into the instance
3. Idle the gear of this app
oo-admin-ctl-gears idlegear 51dba7143b25920a0d000003
4. Show status of this app
rhc app show --state cphp03
5. List the idled gears
oo-admin-ctl-gears listidle
6. Count the numbers of idled gears
oo-idler-stats

Actual results:
at Step4: Cartridge php-5.3 is idle
at Step5: return nothing 
at Step6: 0 running, 0 idled, 0 half-idled for a total 0 of 1 (0.00 %)

Expected results:
Should detect the idled gears

Additional info:
Comment 1 Mrunal Patel 2013-07-09 15:17:49 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=982523 is most likely the root cause.
Comment 2 Rob Millner 2013-07-09 16:31:56 EDT
Cannot reproduce on the latest devenv (devenv_3468).

# oo-admin-ctl-gears idlegear 364263657654602396860416
Idling gear 364263657654602396860416... [ OK ]

# rhc app show --state rm1
Cartridge php-5.3 is idle

# oo-admin-ctl-gears listidle
364263657654602396860416 is idled

# oo-idler-stats
0 running, 1 idled, 0 half-idled for a total 1 of 1 (100.00 %)


There have been a number of bug fixes over the past day - this was likely caused by one of the issues fixed in another bug.

Passing back to Q/E to re-check.
Comment 3 chunchen 2013-07-09 22:08:50 EDT
This issue is fixed, checked on devenv_3471,please refer to the following results:

# oo-admin-ctl-gears listidle
51dcc0960ef4360893000001 is idled

# oo-idler-stats
2 running, 1 idled, 0 half-idled for a total 3 of 3 (100.00 %)

Note You need to log in before you can comment on or make changes to this bug.