Bug 982543 - inconsistent display of days in TasksList > Month view
inconsistent display of days in TasksList > Month view
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 05:21 EDT by Jan Hrcek
Modified: 2014-08-06 16:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing days in calendar view (59.98 KB, image/png)
2013-07-09 05:21 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-07-09 05:21:33 EDT
Created attachment 770868 [details]
Missing days in calendar view

Description of problem:
When using Month view of Tasks list, most of the months have all the days alligned in 7 (days) x 5 (weeks) grid. The grid is filled with days of previous/following months if the grid is not completely filled with the days of current month.

However for some months, the grid is not correctly filled with days from the next month. Also in some months there are some days completely missing.

Version-Release number of selected component (if applicable):
6.0.0.Beta 5

How reproducible:
Always in my environment (Firefox 22 / Fedora 19)

Steps to Reproduce:
1. Go to Tasks > Tasks List, select Month view
2. click through the months, and notice the discrepancies


Actual results:
Especially notice:
March  (2014) - is missing the whole 5 days from Monday 24 till Friday 28 (similarly there seems to be the problem for all the Marches - probably because of 28/29 day February preceeds this month)

October (2013) - contains only 2 days of following month - 1 day is missing to 
complete the grid

February (2013) - contains NO days of following month - 3 day are missing to complete the grid

Expected results:
-All days of selected month should be displayed (see the case of March)
-when days of following/previous month are used to complete the 5x7 grid the grid should be filled in completely or none at all for all months (no days from next month should be used) to ensure consistent display
Comment 1 Jan Hrcek 2013-07-09 06:55:36 EDT
Edit: Actually the reportedly missing days of March are not missing, but they are displayed out of order (in the "first week" of the calendar).

Also important to notice is that grid 5x7 is not large enough to display all days of all possible months. e.g. take a month that starts on saturday and has 31 days -> it spans 6 weeks - for example try to display July 2017. As it is, the 31th of July is not displayed in the Month view.
Comment 2 Mauricio Salatino 2013-07-16 07:37:27 EDT
This issue was partially fixed. Now all the months are displayed correctly except march 2014. I'm suspecting about the Locale Timezones, but I will dig deeper to find what is going on with that particular month
Comment 5 Jan Hrcek 2013-07-30 01:04:42 EDT
The issue with missing days is fixed, but new issue has been introduced by these fixes : now it can happen, that the entire month January gets skipped when navigating through months using next/today/previous buttons.

Please follow these steps to reproduce the issue:
1) Go to Task list,  add 1 task using New Task button
2) Switch to view Month/Active
3) Using calendar navigation button ">" (next to Today button) navigate to January 14
4) Click ">" again - February is not displayed - instead the app skips to March 14

5) You can observe similar issue when returning back to February 13 - although for this month it is actually present then I scroll back (using "<" I see: March 13 - February 13 - January 13, then I go forward ">" and February 13 is skipped, instead I go to March 13 directly)
Comment 6 Mauricio Salatino 2013-08-07 05:03:39 EDT
Fixed https://github.com/droolsjbpm/jbpm-console-ng/commit/74cb096e51ee3269f7c33931c3f002ded5fe2d95

Thanks to Petr Siroky !
Comment 7 Jan Hrcek 2013-09-04 03:14:20 EDT
Verified with BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.