Bug 982612 - dracut >= 025 ships confusingly named script ('sosreport')
dracut >= 025 ships confusingly named script ('sosreport')
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:12 EDT by Bryn M. Reeves
Modified: 2013-08-20 11:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 08:51:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2013-07-09 08:12:20 EDT
Description of problem:
The dracut troubleshooting documentation describes a file created in /run/initramfs when there is a problem during early boot. The name of the file is 'sosreport.txt' and it does not seem possible to change this.

This is an extremely confusing name for users as the standard support data collection tool in the distribution has been named 'sosreport' for many years. There are many documents that refer to generating an 'sosreport' or advising users to 'please send an sosreport'.

Having to distinguish the system sosreport vs. dracut sosreport is going to be extremely confusing and will certainly result in some cases where the wrong information is provided.

The system sosreport ('sos' package) is now being adopted by Ubuntu and Debian so the confusion is just going to propagate among distros.

Version-Release number of selected component (if applicable):
dracut >= 025

How reproducible:
100%

Steps to Reproduce:
1. rpm -ql dracut | grep sosreport

Actual results:
modules.d/99base/sosreport.sh

Expected results:
<nothing>

We'd like to see the script renamed to something unambiguous that makes it clear that it is not related to the existing sosreport script installed in /usr/sbin.

Additional info:
https://github.com/sosreport/sosreport
http://pkgs.fedoraproject.org/cgit/sos.git
Comment 1 Harald Hoyer 2013-08-20 08:51:27 EDT
renamed to rdsosreport.txt
Comment 2 Bryn M. Reeves 2013-08-20 11:58:11 EDT
Wouldn't dracut-debug.txt or something be clearer still?

"rdsosreport.txt" still sounds like it has something to do with the sosreport command ('sosreport' isn't really a generic term for anything - it is one of the reasons that name was chosen to replace the previous tool 'sysreport').

Note You need to log in before you can comment on or make changes to this bug.