Bug 982617 - [vdsm] getImagesList returns ordered hash with each letter on new line (NFS only)
[vdsm] getImagesList returns ordered hash with each letter on new line (NFS o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
All Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Jakub Libosvar
storage
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:15 EDT by Jakub Libosvar
Modified: 2016-02-10 13:18 EST (History)
11 users (show)

See Also:
Fixed In Version: is6
Doc Type: Bug Fix
Doc Text:
Previously, the getImagesList command on an NFS domain returned an ordered hash with each letter on a new line. This problem has been fixed, now getImagesList retrieves a correctly rendered list of images.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:27:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16830 None None None Never

  None (edit)
Description Jakub Libosvar 2013-07-09 08:15:28 EDT
Description of problem:
Calling getImagesList doesn't return list of images
[root@puma27 f62c3fa9-3727-4c3c-a1d2-6b5a43f2c217]# ll /rhev/data-center/eab0122c-10f5-4802-bfd3-f47a01ec9b5c/08b71a28-e356-42e6-bff8-4e191090a8d1/images/
total 4
drwxr-xr-x. 2 vdsm kvm 4096 Jul  9  2013 f62c3fa9-3727-4c3c-a1d2-6b5a43f2c217
[root@puma27 f62c3fa9-3727-4c3c-a1d2-6b5a43f2c217]# vdsClient -s 0 getImagesList 08b71a28-e356-42e6-bff8-4e191090a8d1a
c
b
d
f
-
1
3
2
5
4
7
6
9


Version-Release number of selected component (if applicable):
vdsm-4.11.0-89.git8bf916a.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. call getImagesList on SD that contains images
2.
3.

Actual results:
see desc

Expected results:
list of images

Additional info:
Thread-5841::DEBUG::2013-07-09 15:14:08,158::BindingXMLRPC::177::vds::(wrapper) client [10.35.160.63]
Thread-5841::DEBUG::2013-07-09 15:14:08,159::task::579::TaskManager.Task::(_updateState) Task=`80cc508b-c5d0-4380-a0ad-e94fe4de424b`::moving from state init -> state preparing
Thread-5841::INFO::2013-07-09 15:14:08,159::logUtils::44::dispatcher::(wrapper) Run and protect: getImagesList(sdUUID='08b71a28-e356-42e6-bff8-4e191090a8d1', options=None)
Thread-5841::DEBUG::2013-07-09 15:14:08,160::resourceManager::197::ResourceManager.Request::(__init__) ResName=`Storage.08b71a28-e356-42e6-bff8-4e191090a8d1`ReqID=`50114ac4-ff68-4178-85a2-b7416b983bc8`::Request was made in '/usr/share/vdsm/storage/hsm.py' line '3241' at 'getImagesList'
Thread-5841::DEBUG::2013-07-09 15:14:08,160::resourceManager::541::ResourceManager::(registerResource) Trying to register resource 'Storage.08b71a28-e356-42e6-bff8-4e191090a8d1' for lock type 'shared'
Thread-5841::DEBUG::2013-07-09 15:14:08,161::resourceManager::600::ResourceManager::(registerResource) Resource 'Storage.08b71a28-e356-42e6-bff8-4e191090a8d1' is free. Now locking as 'shared' (1 active user)
Thread-5841::DEBUG::2013-07-09 15:14:08,161::resourceManager::237::ResourceManager.Request::(grant) ResName=`Storage.08b71a28-e356-42e6-bff8-4e191090a8d1`ReqID=`50114ac4-ff68-4178-85a2-b7416b983bc8`::Granted request
Thread-5841::DEBUG::2013-07-09 15:14:08,162::task::811::TaskManager.Task::(resourceAcquired) Task=`80cc508b-c5d0-4380-a0ad-e94fe4de424b`::_resourcesAcquired: Storage.08b71a28-e356-42e6-bff8-4e191090a8d1 (shared)
Thread-5841::DEBUG::2013-07-09 15:14:08,162::task::974::TaskManager.Task::(_decref) Task=`80cc508b-c5d0-4380-a0ad-e94fe4de424b`::ref 1 aborting False
Thread-5841::INFO::2013-07-09 15:14:08,169::logUtils::47::dispatcher::(wrapper) Run and protect: getImagesList, Return response: {'imageslist': ['a', 'c', 'b', 'd', 'f', '-', '1', '3', '2', '5', '4', '7', '6', '9']}
Thread-5841::DEBUG::2013-07-09 15:14:08,169::task::1168::TaskManager.Task::(prepare) Task=`80cc508b-c5d0-4380-a0ad-e94fe4de424b`::finished: {'imageslist': ['a', 'c', 'b', 'd', 'f', '-', '1', '3', '2', '5', '4', '7', '6', '9']}
Thread-5841::DEBUG::2013-07-09 15:14:08,169::task::579::TaskManager.Task::(_updateState) Task=`80cc508b-c5d0-4380-a0ad-e94fe4de424b`::moving from state preparing -> state finished
Comment 2 Jakub Libosvar 2013-07-10 02:58:52 EDT
Doesn't reproduce on iscsi
Comment 4 Jakub Libosvar 2013-07-18 08:29:21 EDT
Verified vdsm-4.12.0-rc1.12.git8ee6885.el6.x86_64
Comment 5 Charlie 2013-11-27 19:28:14 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:27:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.