Bug 982620 - Remote applications (un)usability (AppMenu)
Remote applications (un)usability (AppMenu)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gtk3 (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
:
Depends On: 1207380
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:22 EDT by Remi Collet
Modified: 2015-11-19 03:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:12:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 703862 None None None Never

  None (edit)
Description Remi Collet 2013-07-09 08:22:37 EDT
Hi.

When application à run remotely (for example from ssh -X) the options from the
AppMenu are missing.

Ex, in gedit: Quit and Preferences.
(Quit is not a real issue, while missing Preferences is really annoying).

I know the tips to disable AppMenu
gsettings set \
  org.gnome.settings-daemon.plugins.xsettings overrides \
  '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}'

This works well locally. But not for remote app (no session / daemon-settings
running).

It will be great to have application to switch to Gtk/ShellShowsAppMenu=0 at
runtime when some condition encountered.


Using graphical gnome application from remote is a quite common usage, I think.

Thanks.
Comment 2 Remi Collet 2013-08-08 03:13:03 EDT
I notice gnome-terminal add Pref / Help entries in both the AppMenu and in the standard menu, which seems a acceptable solution.
Comment 4 Florian Müllner 2014-04-26 08:42:57 EDT
GtkApplication is expected to fallback to an in-window app menu if it cannot be displayed by the shell. It currently only handles the case where the desktop does not support app menus at all, it needs to handle the case where desktop shell and application use different DBus sessions as well - see https://bugzilla.gnome.org/show_bug.cgi?id=671802.
Comment 9 errata-xmlrpc 2015-11-19 03:12:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2116.html

Note You need to log in before you can comment on or make changes to this bug.