Bug 982631 - AttributeError: 'NoneType' object has no attribute 'type'
AttributeError: 'NoneType' object has no attribute 'type'
Status: CLOSED DUPLICATE of bug 960794
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:63feca39a816a74e2ecdca0108c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 08:48 EDT by roger.vins.11
Modified: 2013-07-15 20:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 20:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (649.56 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: anaconda.log (17.36 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: environ (440 bytes, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: lsblk_output (2.32 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: messages (229.08 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: nmcli_dev_list (3.44 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: program.log (49.18 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: storage.log (225.34 KB, text/plain)
2013-07-09 08:48 EDT, roger.vins.11
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-07-09 08:49 EDT, roger.vins.11
no flags Details

  None (edit)
Description roger.vins.11 2013-07-09 08:48:01 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/platform.py", line 107, in bestDiskLabelType
    labelType = self.requiredDiskLabelType(device.partedDevice.type)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 816, in initializeDisk
    labelType = _platform.bestDiskLabelType(disk)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2022, in _destroy_device
    self.__storage.initializeDisk(device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2146, in on_remove_clicked
    self._destroy_device(dev)
AttributeError: 'NoneType' object has no attribute 'type'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/ubninit root=UUID=6CFB-23E8 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/ubnkern 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 roger.vins.11 2013-07-09 08:48:15 EDT
Created attachment 771000 [details]
File: anaconda-tb
Comment 2 roger.vins.11 2013-07-09 08:48:20 EDT
Created attachment 771001 [details]
File: anaconda.log
Comment 3 roger.vins.11 2013-07-09 08:48:24 EDT
Created attachment 771002 [details]
File: environ
Comment 4 roger.vins.11 2013-07-09 08:48:28 EDT
Created attachment 771003 [details]
File: lsblk_output
Comment 5 roger.vins.11 2013-07-09 08:48:35 EDT
Created attachment 771004 [details]
File: messages
Comment 6 roger.vins.11 2013-07-09 08:48:39 EDT
Created attachment 771005 [details]
File: nmcli_dev_list
Comment 7 roger.vins.11 2013-07-09 08:48:43 EDT
Created attachment 771006 [details]
File: os_info
Comment 8 roger.vins.11 2013-07-09 08:48:49 EDT
Created attachment 771007 [details]
File: program.log
Comment 9 roger.vins.11 2013-07-09 08:48:58 EDT
Created attachment 771008 [details]
File: storage.log
Comment 10 roger.vins.11 2013-07-09 08:49:02 EDT
Created attachment 771009 [details]
File: ifcfg.log
Comment 11 Brian Lane 2013-07-15 20:26:53 EDT

*** This bug has been marked as a duplicate of bug 960794 ***

Note You need to log in before you can comment on or make changes to this bug.