Bug 982647 - User can't see networks in DC when he has NetworkUser role on that DC.
User can't see networks in DC when he has NetworkUser role on that DC.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Moti Asayag
Meni Yakove
network
: TestBlocker, Triaged, ZStream
Depends On:
Blocks: 998254
  Show dependency treegraph
 
Reported: 2013-07-09 09:28 EDT by Ondra Machacek
Modified: 2016-02-10 14:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 998254 (view as bug list)
Environment:
Last Closed: 2013-08-19 06:53:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2013-07-09 09:28:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):
3.2.1-0.39.el6ev (sf18.3)

How reproducible:
100%

Steps to Reproduce:
1. Create private networks in DC.
2. Assign NetworkUser on that DC to user1.
3. As user1 check /api/networks

Actual results:
User can't see private networks.

Expected results:
User should see private networks.

Additional info:
Comment 2 Moti Asayag 2013-08-18 05:28:31 EDT
This bug is no longer relevant for 3.3 since the network usage visibility was modified to Vnic Profiles level and VnicProfileUser replaced the NetworkUser role.
Comment 4 lpeer 2013-08-18 11:59:18 EDT
I'm removing the 3.3 flag per comment#2

Note You need to log in before you can comment on or make changes to this bug.