Bug 982648 - Teiid Designer preference for Teiid Server version should default to 8.4
Teiid Designer preference for Teiid Server version should default to 8.4
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid, Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 09:31 EDT by Van Halbert
Modified: 2014-07-09 01:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:37:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-1777 Critical Closed Unable to connect to a remote domain server 2014-05-22 17:48:40 EDT
JBoss Issue Tracker TEIIDDES-1778 Major Closed Change the Teiid Server version in the preferences to 8.4 2014-05-22 17:48:40 EDT

  None (edit)
Comment 3 JBoss JIRA Server 2013-07-09 13:57:44 EDT
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIIDDES-1777

This one can be closed.  Didn't realize there's a server version preference to set.  It doesn't default to 8.4, hence the issue.  I've logged a jira to get the default changed.
Comment 4 JBoss JIRA Server 2013-07-11 11:10:58 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> made a comment on jira TEIIDDES-1778

Van,

Can you be more specific about the preference, ie. is the actual value of
Window > Preferences > Teiid Designer > Default Server Version set to "8.3.x"?

Is this a clean workspace that you have not set the preference on before?

Reasons for asking:
* A clean workspace has no preference set at all with the last-resort default server version set to 8.0.0 (which I have now amended to 8.4.0)
* Once the preference is set, it is stored in the workspace and reflects a decision by the user hence should not be updated
Comment 5 JBoss JIRA Server 2013-07-11 11:30:45 EDT
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIIDDES-1778

Yes, this was a clean keplar install with the latest 8.2 nightly of Designer.
Comment 6 JBoss JIRA Server 2013-07-12 11:17:04 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> made a comment on jira TEIIDDES-1778

Attached a screenshot of a new workspace with a nightly install. As can be seen, the default server preference is empty and thus the server version is 8.0.0 (the last resort default).

I have updated the last resort default to 8.4.0 but I cannot work out how 8.3.x could be the default server version.
Comment 7 JBoss JIRA Server 2013-07-22 08:22:46 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> updated the status of jira TEIIDDES-1778 to Resolved
Comment 8 JBoss JIRA Server 2013-07-22 08:22:46 EDT
Paul Richardson <p.g.richardson@phantomjinx.co.uk> made a comment on jira TEIIDDES-1778

Fixed.

For a new workspace, the latest teiid runtime client plugin version should be chosen and if there are none (unlikely!) then a hard-coded default will be used.
Comment 9 JBoss JIRA Server 2013-07-24 08:10:58 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-1777 to Closed
Comment 10 JBoss JIRA Server 2013-07-24 08:10:58 EDT
Barry LaFond <blafond@jboss.org> made a comment on jira TEIIDDES-1777

Covered under TEIIDDES-1779
Comment 14 belong 2013-11-19 18:24:47 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 15 Lucie Fabrikova 2014-02-04 12:02:52 EST
Verified in JBDSIS-7.0.0.GA-GA + DV 6.0.0.GA.
Comment 16 JBoss JIRA Server 2014-05-07 17:15:04 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-1778 to Closed

Note You need to log in before you can comment on or make changes to this bug.