Bug 982652 - intermittent failure of org.jboss.as.test.integration.ws.wsa.TestRequiredAddressingTestCase
intermittent failure of org.jboss.as.test.integration.ws.wsa.TestRequiredAddr...
Status: CLOSED DUPLICATE of bug 908701
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 09:45 EDT by Aleksandar Kostadinov
Modified: 2014-08-20 06:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-20 06:51:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
usingLocalWSDLWithOptionalAddressing error (39.70 KB, text/plain)
2013-07-09 09:46 EDT, Aleksandar Kostadinov
no flags Details
usingLocalWSDLWithAddressing error (39.69 KB, text/plain)
2013-07-09 09:47 EDT, Aleksandar Kostadinov
no flags Details

  None (edit)
Description Aleksandar Kostadinov 2013-07-09 09:45:41 EDT
Intermittent could not send message with:
> org.jboss.as.test.integration.ws.wsa.TestRequiredAddressingTestCase
> .usingLocalWSDLWithOptionalAddressing
> .usingLocalWSDLWithAddressing

See full error messages and stack traces in attachments.

Reference test jobs:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-61-smoketest-as-testsuite-RHEL6_x86-local-repo-PoC/lastCompletedBuild/testReport/
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-openJDK6
Comment 1 Aleksandar Kostadinov 2013-07-09 09:46:44 EDT
Created attachment 771023 [details]
usingLocalWSDLWithOptionalAddressing error
Comment 2 Aleksandar Kostadinov 2013-07-09 09:47:31 EDT
Created attachment 771027 [details]
usingLocalWSDLWithAddressing error
Comment 3 Petr Sakař 2013-09-09 06:26:19 EDT
AFAIK this is jdk issue
 https://issues.apache.org/jira/browse/CXF-4857?page=com.atlassian.jirafisheyeplugin:fisheye-issuepanel
 see http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8009650
 see https://forums.oracle.com/thread/2190450
 http://lists.jboss.org/pipermail/jboss-as7-dev/2013-January/007509.html
 https://fisheye6.atlassian.com/viewrep/cxf/branches/2.6.x-fixes/rt/transports/http/src/main/java/org/apache/cxf/transport/http/HTTPConduit.java?r1=&r2=1450511
 https://fisheye6.atlassian.com/changelog/cxf?cs=1450511

I've consulted it with Alession Soldano and we agreed to wait for next upgrade of jdk which should contain fix and in the meantime write down the list of jdk/OS combinations where we see the issue during next test cycle.
It the issue will not be resolved by jdk upgrade, we will investigate more.
Comment 5 Pavel Jelinek 2014-08-20 06:51:38 EDT

*** This bug has been marked as a duplicate of bug 908701 ***

Note You need to log in before you can comment on or make changes to this bug.