This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 982658 - Application records in mongo seem to have gotten broken.
Application records in mongo seem to have gotten broken.
Status: CLOSED DUPLICATE of bug 982436
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 09:58 EDT by Luke Meyer
Modified: 2015-05-14 20:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 21:30:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-07-09 09:58:12 EDT
Description of problem:
On Wednesday 07/03 I created application mydiy-sosiouxme specifying a cartridge to download:
rhc app create  mydiy   "http://cartreflect-claytondev.rhcloud.com/reflect?github=sosiouxme/diy-extra-port-cartridge&commit=ssl-hack" --no-git --no-dns
It was created and I proceeded to add an IRC proxy to it and use it as such since then by forwarding the port. I have been doing this daily and didn't make any other changes since then.

This morning I tried rhc port-forward on it and received an error. Even doing "rhc apps" gets me an error.

How reproducible:
No idea, this is the only instance seen so far AFAIK, and it took nearly a week to manifest.

Actual results:
Adding --debug tells me the port forward is failing like so:
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/sosiouxme/applications/mydiy
DEBUG:    code 500   45 ms
DEBUG: Response did not include a message from server: invalid character at "<!DOCTYPE "
The server did not respond correctly. [...]

On "rhc apps" I get a similar result for:
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/sosiouxme/applications?include=cartridges

BTW, I can continue to ssh into the gear and port-forward manually. It is still there and working. I just can't access it via the broker and given that "rhc apps" is broken it's kind of a nuisance for other apps I own too, which is why I thought it's high severity in case anyone else runs into this.

Expected results:
Broker access should work exactly like it did each day before now :)

Additional info:
This is not an important app. I authorize whatever looking around or adjustment is needed for debugging, up to and including deleting it. I'm thinking there is at least a 50% chance that me deleting it would work and fix my issue, but that wouldn't be a good solution for most.
Comment 2 Abhishek Gupta 2013-07-09 19:56:21 EDT
Can you please verify if your application is now fixed?
Comment 3 Rajat Chopra 2013-07-09 21:30:38 EDT

*** This bug has been marked as a duplicate of bug 982436 ***
Comment 4 Luke Meyer 2013-07-10 08:49:28 EDT
Looks good, thanks :)

Note You need to log in before you can comment on or make changes to this bug.