Bug 982677 - horizon: cannot see conformation message when removing a snapshot from the button of the list (message appears at the top of the screen)
horizon: cannot see conformation message when removing a snapshot from the bu...
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: 5.0 (RHEL 7)
Assigned To: Julie Pichon
Ami Jeain
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 10:35 EDT by Dafna Ron
Modified: 2015-06-04 17:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 12:47:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot and logs (138.66 KB, application/x-gzip)
2013-07-09 10:35 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1251361 None None None Never

  None (edit)
Description Dafna Ron 2013-07-09 10:35:35 EDT
Created attachment 771058 [details]
screen shot and logs

Description of problem:

I am working with nfs remote storage on two computes. 
when we try to create a snapshot for a volume its not yet implemented and the snapshot is created in status Error. 
when I try to remove the snapshot the UI gets stuck (see screen shot) 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.1.2-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. install a set up with two computes with packstack (AIO + 1 nova) with remote nfs storage for cinder
2. create a volume 
3. try to create a snapshot
4. try to delete the snapshot

Actual results:

UI is stuck

Expected results:

we should be able to remove the snapshot

Additional info:
Comment 1 Julie Pichon 2013-07-17 06:39:12 EDT
Thank you for attaching a screenshot. I think this may be a small UI hiccup: could you try scrolling up when this happens again? I suspect the confirmation message is showing at the top of the screen, asking you to confirm the deletion before proceeding.
Comment 2 Dafna Ron 2013-07-17 07:41:51 EDT
yes, you are right :) I did not even notice that because I had a long list of snapshots and the message was in the top of the screen.
Comment 3 Julie Pichon 2013-07-17 07:57:54 EDT
Yes, we should focus on the modal when it appears.
Comment 4 Julie Pichon 2013-11-14 12:47:40 EST
Bug opened upstream. IMO this should be tracked upstream only, as this is a low priority small impact UX improvement. Thanks!

https://bugs.launchpad.net/horizon/+bug/1251361

Note You need to log in before you can comment on or make changes to this bug.