Bug 98271 - (PCMCIA)2.4.20 Crashes at Boot w/ Ethernet/Modem PCMCIA Card Installed
(PCMCIA)2.4.20 Crashes at Boot w/ Ethernet/Modem PCMCIA Card Installed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 02:35 EDT by Ronald W. Heiby
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronald W. Heiby 2003-06-30 02:35:45 EDT
Description of problem:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello linux-thinkpad,

I'm running RH 8.0 on my 770ED. The system sits on a dock where the
floppy resides, along with a TDK CD-RW drive. On the dock's SCSI,
there is a Syquest SyJet with no disk in the drive. In the PCMCIA
slot, I have a 3Com/Megahertz 3CCFEM556 Ethernet/Modem card.

Running kernel 2.4.18-27.0, and several others before that, things
have been working pretty well. However, when I tried moving to the
first 2.4.20 kernel update that RH released, I had trouble. After
seeing some discussion here, it looked like it might have been caused
by PCMCIA difficulties. It looked more like that once I successfully
upgraded my A21p and three desktop systems (none of which use any
PCMCIA cards).

Now, I've tried upgrading to the latest 2.4.20-18.8, and my system is
still locking up at boot time. I am assuming that this is a "panic",
but since I can't remember seeing one on Linux before and since it
goes on for enough lines to scroll off the top of the screen, who
knows?

In /var/log/messages, the last few lines from my 2.4.20-18.8 boot
attempt are (without the date stamps):

pcmcia:  cardmgr.
cardmgr[598]: starting, version is 3.1.31
rc: Starting pcmcia:  succeeded
cardmgr[598]: config error, file 'config' line 2129: no function
bindings
cardmgr[598]: watching 4 sockets
cardmgr[598]: Card services release does not match

Note that the complaint about line 2129 also happens in the 2.4.18
boot. Note that the "Card services release does not match" complaint
also happens in the 2.4.18 boot.

In the 2.4.18 boot, what follows are lines from kernel/cs relating to
IO port probing, followed by the initialization of the Ethernet/Modem
card.

So, I guess I'm still suspicious of PCMCIA issues. Further evidence
pointing at PCMCIA is that when I pulled the card and re-booted, the
system came up fine (althouth, of course, not on the network).

Where do I go from here??? Thanks!

Ron.

-----BEGIN PGP SIGNATURE-----
Version: PGP Personal Privacy 6.5.8
Comment: Until recently, the last PGP with full source disclosure.

iQA/AwUBPua2dm8pw+2/9pUJEQI7AACeKKQFURSVE3eXq8nBGYVWMC8sVZsAoOuD
7KQ3bTP4K8m9dW0qR1u7CILS
=f2iu
-----END PGP SIGNATURE-----

How reproducible:
Always

Steps to Reproduce:
1. Leave Ethernet/Modem card installed
2. Power on ThinkPad
3. Observer Crash and Burn
    
Actual results:
System refuses to boot

Expected results:
Normal boot with Ethernet connectivity
Comment 1 Bugzilla owner 2004-09-30 11:41:13 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.