Bug 982719 - Compile with RawSpeed codec
Compile with RawSpeed codec
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: LibRaw (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 12:27 EDT by nucleo
Modified: 2013-07-15 13:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 13:56:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2013-07-09 12:27:59 EDT
Description of problem:
libkdcraw have possibility to build optionally internal copy of LibRaw with RawSpeed codec.
Now it is possible to build libkdcraw against external LibRaw >= 0.15 but system package LibRaw built without RawSpeed.
Looks like RawSpeed disabled at this moment by LibRaw upstream (commented in Makefile) but can we enable it?

Version-Release number of selected component (if applicable):
LibRaw-0.15.2-1.fc20
Comment 1 Gwyn Ciesla 2013-07-09 13:36:22 EDT
The docs mention using RawSpeed/rawspeed.cpucount-unix.patch, which applies against a file not present in LibRaw.  RawSpeed is not in Fedora, and I can't find a release available, except as part of rawstudio, which is in Fedora, but without RawSpeed.

Adding rawstudio maintainer.

Since rawstudio is the upstream for RawSpeed, and LibRaw wants a patch applied to RawSpeed, it seems that the best path forward would be to package RawSpeed applying the LibRaw patch, add that to Fedora, and have LibRaw then build with that.  The problem is there don't seem to be releases, only svn:

http://rawstudio.org/svn/rawspeed/

Which I can't figure out how to build, and

http://rawstudio.org/svn/rawstudio/trunk/plugins/load-rawspeed/

Which is part of rawstudio, but might provide guidance on how to build it.

All in all, it look like a non-trivial effort, and with no upstream releases we'd have to decide on our own soname, and decide when to increment it.  Gianluca, to you have anything to add to this?
Comment 2 Kevin Kofler 2013-07-09 16:47:27 EDT
I think you're expected to add RawSpeed to the LibRaw build tree and then build the whole thing as one library. At least that's how libkdcraw does/did it.
Comment 3 Gwyn Ciesla 2013-07-10 07:52:26 EDT
That was my understanding as well.  But if the only way to add RawSpeed support is to bundle it, I'll pass.  That's why I was soliciting alternative suggestions.
Comment 4 Kevin Kofler 2013-07-10 19:08:28 EDT
Well, "bundling" is not the right term here. RawSpeed is not a standalone library, it's a "patch" for LibRaw (mostly constituted of added files, though as I understand it, some other LibRaw code is then not used, replaced by the RawSpeed code).
Comment 5 Gwyn Ciesla 2013-07-11 09:27:52 EDT
If it's outright replacing LibRaw code, then it's a fork.
Comment 6 Kevin Kofler 2013-07-11 17:47:00 EDT
And the point of this request is that we should be packaging RawSpeed-enhanced LibRaw rather than stock LibRaw, just as we're packaging, e.g., libjpeg-turbo rather than IJG libjpeg.
Comment 7 Gwyn Ciesla 2013-07-12 08:30:17 EDT
Ok, that's a different issue.  But I'm still not convinced.  What benefits does that bring us over LibRaw that justify moving from a project with stable releases to a fork that doesn't seem to offer them?
Comment 8 Gianluca Sforna 2013-07-14 11:47:14 EDT
rawstudio guys seem active but they have done less and less releases lately, relying on some ppa for their primary distribution.

However, reading all of this I tend to think either a proper librawspeed fork emerges, or rawstudio guys submits their patches upstream. As is, I don't think there is much space to make a package for librawspeed: too much downstream work to make it useful.
Comment 9 Gwyn Ciesla 2013-07-15 13:56:15 EDT
My thoughts exactly.  Feel free to reopen when either a fork is released or this is released buildable upon existing LibRaw.

Note You need to log in before you can comment on or make changes to this bug.