Bug 982745 - [abrt] liveusb-creator-3.11.8-3.fc19: gui.py:468:status:TypeError: QTextEdit.append(QString): argument 1 has unexpected type 'int'
[abrt] liveusb-creator-3.11.8-3.fc19: gui.py:468:status:TypeError: QTextEdit....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
abrt_hash:28fc4bf3c24b85ddf84f8b5ca6a...
:
: 1104964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 14:40 EDT by Jeff Raber
Modified: 2016-09-19 22:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-20 15:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (412 bytes, text/plain)
2013-07-09 14:40 EDT, Jeff Raber
no flags Details
File: environ (278 bytes, text/plain)
2013-07-09 14:40 EDT, Jeff Raber
no flags Details

  None (edit)
Description Jeff Raber 2013-07-09 14:40:26 EDT
Description of problem:
Start 'Fedora LiveUSB Creator'
Choose an F18 (x86_64) ISO and an flash drive.
Press "Create Live USB"
Below is the text displayed in the 'Live USB Creator window", the crash appears just as the final 3 lines are printed.

Fedora-18-x86_64-Live-Desktop.iso selected
Verifying filesystem...
Verifying ISO MD5 checksum
ISO MD5 checksum passed
Verifying SHA256 checksum of LiveCD image...
Extracting live image to USB device...
Wrote to device at 10 MB/sec
Setting up OLPC boot file...
Installing bootloader...
2
LiveUSB creation failed!

Version-Release number of selected component:
liveusb-creator-3.11.8-3.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -tt /usr/sbin/liveusb-creator
core_backtrace: 039cd1713245aa57aa39aefb1172c645560bc811 0x1d4 status /usr/lib/python2.7/site-packages/liveusb/gui.py -
executable:     /usr/sbin/liveusb-creator
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
gui.py:468:status:TypeError: QTextEdit.append(QString): argument 1 has unexpected type 'int'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 468, in status
    self.textEdit.append(text)
TypeError: QTextEdit.append(QString): argument 1 has unexpected type 'int'

Local variables in innermost frame:
text: 2
self: <liveusb.gui.LiveUSBDialog object at 0x2470a70>

Potential duplicate: bug 982392
Comment 1 Jeff Raber 2013-07-09 14:40:31 EDT
Created attachment 771190 [details]
File: backtrace
Comment 2 Jeff Raber 2013-07-09 14:40:34 EDT
Created attachment 771191 [details]
File: environ
Comment 3 Luke Macken 2014-09-20 15:09:36 EDT
*** Bug 1104964 has been marked as a duplicate of this bug. ***
Comment 4 Luke Macken 2014-09-20 15:22:47 EDT
This issue should be resolved in the current version of the liveusb-creator.
Comment 5 Radek Vokal 2014-09-27 06:55:31 EDT
I can still reproduce this with 3.12.0-1.fc20 package
Comment 6 Thomas Spura 2014-10-07 04:39:10 EDT
(In reply to Radek Vokal from comment #5)
> I can still reproduce this with 3.12.0-1.fc20 package

Same here:
gui.py:470:status:TypeError: QTextEdit.append(QString): argument 1 has unexpected type 'int'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 470, in status
    self.textEdit.append(text)
TypeError: QTextEdit.append(QString): argument 1 has unexpected type 'int'

Local variables in innermost frame:
text: 2
self: <liveusb.gui.LiveUSBDialog object at 0x28b19e0>

Just trying it again worked for me though. Here is the output in the liveusb-creator window:
CentOS-7.0-1406-x86_64-livecd.iso selected
Verifying filesystem...
Setting /dev/sdb1 label to LIVE
Verifying ISO MD5 checksum
ISO MD5 checksum passed
Extracting live image to USB device...
Wrote to device at 3 MB/sec
Creating 106MB persistent overlay
Setting up OLPC boot file...
Installing bootloader...
2
LiveUSB creation failed!
Your device already contains a LiveOS.
If you continue, this will be overwritten.
Warning: Creating a new persistent overlay will delete your existing one.
Press 'Create Live USB' again if you wish to continue.
Verifying filesystem...
Setting /dev/sdb1 label to LIVE
Verifying ISO MD5 checksum
ISO MD5 checksum passed
Extracting live image to USB device...
Wrote to device at 3 MB/sec
Creating 106MB persistent overlay
Setting up OLPC boot file...
Installing bootloader...
Unmounting /run/media/$USER/Lexar
Complete! (0:03:53)
Comment 7 Pavel Malyshev 2014-10-25 05:04:23 EDT
The issue is still there in liveusb-creator-3.12.0-1.fc20.noarch according to failure parsed by abrt.

Note You need to log in before you can comment on or make changes to this bug.