Bug 982754 - After upgrading from 3.0 to 3.1, Customer is unable to see reports
After upgrading from 3.0 to 3.1, Customer is unable to see reports
Status: CLOSED DUPLICATE of bug 975221
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.1.3
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Yaniv Lavi
David Botzer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 15:26 EDT by Anitha Udgiri
Modified: 2016-02-10 14:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 20:07:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anitha Udgiri 2013-07-09 15:26:02 EDT
Description of problem:
User is unable to see any reports since upgrading from RHEV 3.0 to 3.1

I see the following errors in ovirt-engine-dwh.log

2013-06-12
10:51:04|aRDY4i|2gkrrN|7pHg0C|OVIRT_ENGINE_DWH|ConfigurationSync|Default|6|Java
Exception|tJDBCInput_15|org.postgresql.util.PSQLException:ERROR:
relation "v3_1_latest_datacenter_configuration_view" does not exist
   Position: 217|1
Exception in component tRunJob_1
java.lang.RuntimeException: Child job running failed
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tRunJob_1Process(SampleRunJobs.java:804)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tJDBCConnection_2Process(SampleRunJobs.java:655)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tJDBCConnection_1Process(SampleRunJobs.java:557)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs$1.run(SampleRunJobs.java:2038)
2013-06-12
10:51:04|7pHg0C|2gkrrN|KoKs3e|OVIRT_ENGINE_DWH|SampleRunJobs|Default|6|Java
Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
Exception in component tRunJob_1
java.lang.RuntimeException: Child job running failed
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tRunJob_1Process(SampleTimeKeepingJob.java:2422)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCInput_2Process(SampleTimeKeepingJob.java:2265)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCConnection_1Process(SampleTimeKeepingJob.java:1437)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCConnection_2Process(SampleTimeKeepingJob.java:1339)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJava_3Process(SampleTimeKeepingJob.java:1247)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJava_1Process(SampleTimeKeepingJob.java:1152)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob$1.run(SampleTimeKeepingJob.java:4242)
2013-06-12
10:51:04|KoKs3e|2gkrrN|zKrDpk|OVIRT_ENGINE_DWH|SampleTimeKeepingJob|Default|6|Java
Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
Exception in component tJDBCInput_15
org.postgresql.util.PSQLException: ERROR: relation
"v3_1_latest_datacenter_configuration_view" does not exist
   Position: 217
	at
org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2062)
	at
org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1795)
	at
org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
	at
org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:479)
	at
org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:353)
	at
org.postgresql.jdbc2.AbstractJdbc2Statement.executeQuery(AbstractJdbc2Statement.java:252)
	at
ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync.tJDBCInput_15Process(ConfigurationSync.java:4030)
	at
ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync.tJDBCInput_2Process(ConfigurationSync.java:3134)
	at
ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync$1.run(ConfigurationSync.java:56044)
2013-06-12
10:52:04|reQQ0A|2gkrrN|fEO21E|OVIRT_ENGINE_DWH|ConfigurationSync|Default|6|Java
Exception|tJDBCInput_15|org.postgresql.util.PSQLException:ERROR:
relation "v3_1_latest_datacenter_configuration_view" does not exist
   Position: 217|1
Exception in component tRunJob_1
java.lang.RuntimeException: Child job running failed
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tRunJob_1Process(SampleRunJobs.java:804)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tJDBCConnection_2Process(SampleRunJobs.java:655)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.tJDBCConnection_1Process(SampleRunJobs.java:557)
	at
ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs$1.run(SampleRunJobs.java:2038)
2013-06-12
10:52:04|fEO21E|2gkrrN|gAyWgX|OVIRT_ENGINE_DWH|SampleRunJobs|Default|6|Java
Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
Exception in component tRunJob_1
java.lang.RuntimeException: Child job running failed
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tRunJob_1Process(SampleTimeKeepingJob.java:2422)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCInput_2Process(SampleTimeKeepingJob.java:2265)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCConnection_1Process(SampleTimeKeepingJob.java:1437)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJDBCConnection_2Process(SampleTimeKeepingJob.java:1339)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJava_3Process(SampleTimeKeepingJob.java:1247)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.tJava_1Process(SampleTimeKeepingJob.java:1152)
	at
ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob$1.run(SampleTimeKeepingJob.java:4242)
2013-06-12
10:52:04|gAyWgX|2gkrrN|zKrDpk|OVIRT_ENGINE_DWH|SampleTimeKeepingJob|Default|6|Java
Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1



Recommended that Customer re-run the setup scripts for dwh and reports post upgrade.
The same error occurs even after the scripts are re-run.

I don't see any problem in the scripts' log files.

What could be happening here?
what log files would you want me to check ?
Comment 1 Yaniv Lavi 2013-07-09 20:53:30 EDT
(In reply to Anitha Udgiri from comment #0)
> Description of problem:
> User is unable to see any reports since upgrading from RHEV 3.0 to 3.1
> 
> I see the following errors in ovirt-engine-dwh.log
> 
> 2013-06-12
> 10:51:
> 04|aRDY4i|2gkrrN|7pHg0C|OVIRT_ENGINE_DWH|ConfigurationSync|Default|6|Java
> Exception|tJDBCInput_15|org.postgresql.util.PSQLException:ERROR:
> relation "v3_1_latest_datacenter_configuration_view" does not exist
>    Position: 217|1
> Exception in component tRunJob_1
> java.lang.RuntimeException: Child job running failed
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tRunJob_1Process(SampleRunJobs.java:804)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tJDBCConnection_2Process(SampleRunJobs.java:655)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tJDBCConnection_1Process(SampleRunJobs.java:557)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs$1.run(SampleRunJobs.java:
> 2038)
> 2013-06-12
> 10:51:04|7pHg0C|2gkrrN|KoKs3e|OVIRT_ENGINE_DWH|SampleRunJobs|Default|6|Java
> Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
> Exception in component tRunJob_1
> java.lang.RuntimeException: Child job running failed
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tRunJob_1Process(SampleTimeKeepingJob.java:2422)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCInput_2Process(SampleTimeKeepingJob.java:2265)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCConnection_1Process(SampleTimeKeepingJob.java:1437)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCConnection_2Process(SampleTimeKeepingJob.java:1339)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJava_3Process(SampleTimeKeepingJob.java:1247)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJava_1Process(SampleTimeKeepingJob.java:1152)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob$1.
> run(SampleTimeKeepingJob.java:4242)
> 2013-06-12
> 10:51:
> 04|KoKs3e|2gkrrN|zKrDpk|OVIRT_ENGINE_DWH|SampleTimeKeepingJob|Default|6|Java
> Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
> Exception in component tJDBCInput_15
> org.postgresql.util.PSQLException: ERROR: relation
> "v3_1_latest_datacenter_configuration_view" does not exist
>    Position: 217
> 	at
> org.postgresql.core.v3.QueryExecutorImpl.
> receiveErrorResponse(QueryExecutorImpl.java:2062)
> 	at
> org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.
> java:1795)
> 	at
> org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
> 	at
> org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.
> java:479)
> 	at
> org.postgresql.jdbc2.AbstractJdbc2Statement.
> executeWithFlags(AbstractJdbc2Statement.java:353)
> 	at
> org.postgresql.jdbc2.AbstractJdbc2Statement.
> executeQuery(AbstractJdbc2Statement.java:252)
> 	at
> ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync.
> tJDBCInput_15Process(ConfigurationSync.java:4030)
> 	at
> ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync.
> tJDBCInput_2Process(ConfigurationSync.java:3134)
> 	at
> ovirt_engine_dwh.configurationsync_3_1.ConfigurationSync$1.
> run(ConfigurationSync.java:56044)
> 2013-06-12
> 10:52:
> 04|reQQ0A|2gkrrN|fEO21E|OVIRT_ENGINE_DWH|ConfigurationSync|Default|6|Java
> Exception|tJDBCInput_15|org.postgresql.util.PSQLException:ERROR:
> relation "v3_1_latest_datacenter_configuration_view" does not exist
>    Position: 217|1
> Exception in component tRunJob_1
> java.lang.RuntimeException: Child job running failed
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tRunJob_1Process(SampleRunJobs.java:804)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tJDBCConnection_2Process(SampleRunJobs.java:655)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs.
> tJDBCConnection_1Process(SampleRunJobs.java:557)
> 	at
> ovirt_engine_dwh.samplerunjobs_3_1.SampleRunJobs$1.run(SampleRunJobs.java:
> 2038)
> 2013-06-12
> 10:52:04|fEO21E|2gkrrN|gAyWgX|OVIRT_ENGINE_DWH|SampleRunJobs|Default|6|Java
> Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
> Exception in component tRunJob_1
> java.lang.RuntimeException: Child job running failed
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tRunJob_1Process(SampleTimeKeepingJob.java:2422)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCInput_2Process(SampleTimeKeepingJob.java:2265)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCConnection_1Process(SampleTimeKeepingJob.java:1437)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJDBCConnection_2Process(SampleTimeKeepingJob.java:1339)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJava_3Process(SampleTimeKeepingJob.java:1247)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob.
> tJava_1Process(SampleTimeKeepingJob.java:1152)
> 	at
> ovirt_engine_dwh.sampletimekeepingjob_3_1.SampleTimeKeepingJob$1.
> run(SampleTimeKeepingJob.java:4242)
> 2013-06-12
> 10:52:
> 04|gAyWgX|2gkrrN|zKrDpk|OVIRT_ENGINE_DWH|SampleTimeKeepingJob|Default|6|Java
> Exception|tRunJob_1|java.lang.RuntimeException:Child job running failed|1
> 
> 
> 
> Recommended that Customer re-run the setup scripts for dwh and reports post
> upgrade.
> The same error occurs even after the scripts are re-run.
> 
> I don't see any problem in the scripts' log files.
> 
> What could be happening here?
> what log files would you want me to check ?

Views are missing, so he either didn't run setup or something really bad happened him database during upgrade. Try to run refreshStoredProcedures.sh script on him machine, if already run the setup.
Check the dwh upgrade log.



Yaniv
Comment 5 Yaniv Lavi 2013-07-17 20:07:35 EDT
In this state use this is a duplicate of the bug 975221.
Use the tips I gave there to resolve the issue.



Yaniv

*** This bug has been marked as a duplicate of bug 975221 ***

Note You need to log in before you can comment on or make changes to this bug.