Bug 982769 - check-mk-agent missing waitmax
check-mk-agent missing waitmax
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: check-mk (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Andrea Veri
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 16:30 EDT by John Reddy
Modified: 2013-09-16 13:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: check-mk-1.2.2p2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 19:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reddy 2013-07-09 16:30:51 EDT
Description of problem:
The program "waitmax" which should be included as part of check-mk-agent is missing.  Waitmax is a necessary component for the "nfsmounts" test.


Version-Release number of selected component (if applicable):
check-mk-agent-1.2.2-3.el6.x86_64


How reproducible:
Easily.


Steps to Reproduce:
Using check-mk-1.2.2-3.el6.src.rpm:

[rpmbuild]$ grep -A 1 waitmax SPECS/check-mk.spec 
# Remove waitmax and its leftarounds, looks like it's a statically linked binary.
rm %{buildroot}%{_datadir}/check_mk/agents/waitmax
rm %{buildroot}%{_datadir}/check_mk/agents/waitmax.c
rm %{buildroot}%{_datadir}/check_mk/agents/Makefile


Additional info:
The above cited Makefile may be run to compile the correct version for the given architecture, and should not be deleted from the RPM, nor the waitmax.c.
Comment 1 John Reddy 2013-07-09 17:08:20 EDT
Additionally, the 'waitmax' binary is used in the following tests in /usr/bin/check-mk-agent:

nfsmounts (already cited)
ipmi_sensors
ntp
nvidia-settings
cups_queues
Comment 2 John Reddy 2013-08-26 15:11:40 EDT
The following change should address the build problem.  However, it is technically architecture specific, as there's a binary that's part of this package.

--- SPECS/check-mk.spec.old     2013-07-09 20:53:37.950308000 +0000
+++ SPECS/check-mk.spec 2013-08-26 19:10:37.295593000 +0000
@@ -62,6 +62,10 @@
 
 %build
 
+# Ensure that waitmax is compiled for the correct architecture
+rm -f waitmax
+make waitmax
+
 %install
 
 # Agent's installation
@@ -70,6 +74,7 @@
 install -m 644 xinetd.conf %{buildroot}%{_sysconfdir}/xinetd.d/check-mk-agent
 
 install -d -m 755 %{buildroot}%{_bindir}
+install -m 755 waitmax %{buildroot}%{_bindir}/waitmax
 install -m 755 check_mk_agent.linux %{buildroot}%{_bindir}/check_mk_agent
 
 install -d -m 755 %{buildroot}%{_datadir}/check-mk-agent
@@ -153,10 +158,6 @@
 rm -rf %{buildroot}%{_docdir}/check_mk/windows/
 rm -rf %{buildroot}%{_datadir}/check_mk/agents/windows/
 
-# Remove waitmax and its leftarounds, looks like it's a statically linked binary.
-rm %{buildroot}%{_datadir}/check_mk/agents/waitmax
-rm %{buildroot}%{_datadir}/check_mk/agents/waitmax.c
-rm %{buildroot}%{_datadir}/check_mk/agents/Makefile
 
 # Remove the packages directory.
 rm -rf %{buildroot}%{_localstatedir}/lib/check_mk/packages/
@@ -191,6 +192,7 @@
 
 %files agent
 %{_bindir}/check_mk_agent
+%{_bindir}/waitmax
 %{_datadir}/check-mk-agent
 %config(noreplace) %{_sysconfdir}/xinetd.d/check-mk-agent
 %config(noreplace) %{_sysconfdir}/check-mk-agent
Comment 3 Andrea Veri 2013-08-29 12:45:16 EDT
Hi,

the fix has been pushed to git and the package is being built in the couple of days.

More details at http://pkgs.fedoraproject.org/cgit/check-mk.git/commit/?id=5723746d58260b64ee3a103f06624ecf9596dc18.
Comment 4 Fedora Update System 2013-08-31 07:32:31 EDT
check-mk-1.2.2p2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/check-mk-1.2.2p2-1.fc19
Comment 5 Fedora Update System 2013-08-31 07:32:58 EDT
check-mk-1.2.2p2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/check-mk-1.2.2p2-1.el6
Comment 6 Fedora Update System 2013-08-31 15:18:43 EDT
Package check-mk-1.2.2p2-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing check-mk-1.2.2p2-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11394/check-mk-1.2.2p2-1.el6
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-09 19:59:56 EDT
check-mk-1.2.2p2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-09-16 13:43:39 EDT
check-mk-1.2.2p2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.