Bug 982803 - Chrony 1.25 does not support kernels 3.0+ and will not start.
Chrony 1.25 does not support kernels 3.0+ and will not start.
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: chrony (Show other bugs)
el6
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 19:10 EDT by Eric Renfro
Modified: 2014-01-28 16:08 EST (History)
1 user (show)

See Also:
Fixed In Version: chrony-1.25-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 16:08:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
chrony 1.27-1 spec (6.68 KB, text/x-rpm-spec)
2013-07-09 19:39 EDT, Eric Renfro
no flags Details

  None (edit)
Description Eric Renfro 2013-07-09 19:10:16 EDT
Description of problem:
Chrony 1.25 in EPEL has a bug that when it detects kernels >= 3.0.0, it will stop and refuse to work. Chrony 1.26 fixed this issue.

Version-Release number of selected component (if applicable):
chrony-1.25-2.el6.x86_64

How reproducible:
Install chrony 1.25 and kernel-lt or kernel-ml from elrepo kernel and bug will show itself, chrony will refuse to start.
Comment 1 Eric Renfro 2013-07-09 19:39:37 EDT
Created attachment 771300 [details]
chrony 1.27-1 spec

Contains a functioning spec for the chrony 1.27, current latest stable from chrony's website. No changes were needed for the build process, and execution seems to be perfectly functional on stock kernel, kernel-lt and kernel-ml from elrepo.
Comment 2 Fedora Update System 2014-01-10 11:24:36 EST
chrony-1.25-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/chrony-1.25-4.el6
Comment 3 Fedora Update System 2014-01-10 18:41:49 EST
Package chrony-1.25-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing chrony-1.25-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0119/chrony-1.25-4.el6
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2014-01-28 16:08:26 EST
chrony-1.25-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.