Bug 982804 - AS7 reload behavior includes hardcoded timeout of 20 seconds
AS7 reload behavior includes hardcoded timeout of 20 seconds
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
All All
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 19:14 EDT by Marc Shirley
Modified: 2014-01-02 15:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 420483 None None None Never

  None (edit)
Description Marc Shirley 2013-07-09 19:14:40 EDT
Description of problem:
AS7 reload operation fails if the management interface takes longer than 20 seconds to come back up after the reload due to a hardcoded timeout in org/rhq/modules/plugins/jbossas7/StandaloneASComponent.java in the waitUntilReloaded() method.

Version-Release number of selected component (if applicable):
JBoss ON 3.1.2


Steps to Reproduce:
Issue will present itself only if there is a delay in the startup that prevents the management interface from coming up in less than 20 seconds.  In that case, the issue can be reproduced by issuing the "Reload" operation, waiting 20 seconds, and observing the failure of the operation in the operation history.

Actual results:
Reloads that take longer than 20 seconds are reported as failures.

Expected results:
Reload operation should report the correct result.  This should most likely be through a configurable timeout or a repurpose of the  BaseServerComponent.waitForServerToStart() method.

Additional info:
This is similar to the issue reported in BZ 966777.
Comment 1 Thomas Segismont 2013-07-16 09:12:28 EDT
Fixed in master

commit 6ad3c87c08631a00cb960a4ffa4c4929329aa6d8
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Jul 16 13:42:50 2013 +0200
Comment 2 Larry O'Leary 2013-09-06 10:30:30 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 3 Libor Zoubek 2013-11-15 05:22:15 EST
verified on ER5. I was not able to reproduce when EAP6 takes more than 20s to reload, although fix oboviously removes hardcoded timeout and relies on general operation timeout .

Note You need to log in before you can comment on or make changes to this bug.