Bug 982836 - [abrt] ibus-1.5.2-7.fc19: bus_dbus_impl_connection_filter_cb: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.5.2-7.fc19: bus_dbus_impl_connection_filter_cb: Process /usr/bi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:b24defc317ee932c47b15b9c24c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 22:10 EDT by Brian J. Green
Modified: 2014-05-12 08:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 00:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.22 KB, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: cgroup (141 bytes, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: core_backtrace (1.90 KB, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: dso_list (2.34 KB, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: environ (953 bytes, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: maps (12.47 KB, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: open_fds (299 bytes, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2013-07-09 22:10 EDT, Brian J. Green
no flags Details

  None (edit)
Description Brian J. Green 2013-07-09 22:10:26 EDT
Version-Release number of selected component:
ibus-1.5.2-7.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon --replace --xim --panel disable
crash_function: bus_dbus_impl_connection_filter_cb
executable:     /usr/bin/ibus-daemon
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jul  7 23:30:14 gf0 abrt[12128]: Saved core dump of pid 11607 (/usr/bin/ibus-daemon) to /var/tmp/abrt/ccpp-2013-07-07-23:30:13-11607 (37330944 bytes)

Truncated backtrace:
Thread no. 1 (7 frames)
 #4 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1459
 #5 on_worker_message_about_to_be_sent at gdbusconnection.c:2414
 #6 _g_dbus_worker_emit_message_about_to_be_sent at gdbusprivate.c:502
 #7 continue_writing at gdbusprivate.c:1496
 #8 continue_writing_in_idle_cb at gdbusprivate.c:1557
 #13 gdbus_shared_thread_func at gdbusprivate.c:278
 #14 g_thread_proxy at gthread.c:798

Potential duplicate: bug 906086
Comment 1 Brian J. Green 2013-07-09 22:10:30 EDT
Created attachment 771331 [details]
File: backtrace
Comment 2 Brian J. Green 2013-07-09 22:10:32 EDT
Created attachment 771332 [details]
File: cgroup
Comment 3 Brian J. Green 2013-07-09 22:10:35 EDT
Created attachment 771333 [details]
File: core_backtrace
Comment 4 Brian J. Green 2013-07-09 22:10:38 EDT
Created attachment 771334 [details]
File: dso_list
Comment 5 Brian J. Green 2013-07-09 22:10:43 EDT
Created attachment 771335 [details]
File: environ
Comment 6 Brian J. Green 2013-07-09 22:10:46 EDT
Created attachment 771336 [details]
File: limits
Comment 7 Brian J. Green 2013-07-09 22:10:49 EDT
Created attachment 771337 [details]
File: maps
Comment 8 Brian J. Green 2013-07-09 22:10:51 EDT
Created attachment 771338 [details]
File: open_fds
Comment 9 Brian J. Green 2013-07-09 22:10:54 EDT
Created attachment 771339 [details]
File: proc_pid_status
Comment 10 fujiwara 2013-07-11 22:17:11 EDT
(In reply to Brian J. Green from comment #0)

#0  0x000000326b435a19 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x000000326b437128 in __GI_abort () at abort.c:90
#2  0x000000326d86bbc6 in g_assertion_message (domain=domain@entry=0x4195d3 "IBUS", file=file@entry=0x419a9f "dbusimpl.c", line=line@entry=1459, func=func@entry=0x41a0c0 <__PRETTY_FUNCTION__.24244> "bus_dbus_impl_connection_filter_cb", message=<optimized out>) at gtestutils.c:1912
#3  0x000000326d86bc24 in g_assertion_message_expr (domain=domain@entry=0x4195d3 "IBUS", file=file@entry=0x419a9f "dbusimpl.c", line=line@entry=1459, func=func@entry=0x41a0c0 <__PRETTY_FUNCTION__.24244> "bus_dbus_impl_connection_filter_cb", expr=expr@entry=0x419aaa "connection != NULL") at gtestutils.c:1923
#4  0x000000000040a4bf in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x2396b70, incoming=0, user_data=0x231d010) at dbusimpl.c:1459


I cannot reproduce your backtrace.
It seems bus_dbus_impl_connection_filter_cb() was called after bus_connection_destroy() was called.
However I guess the root cause is not ibus.

Are you still able to see the same backtrace?
Comment 11 John Griffiths 2013-09-08 11:39:56 EDT
This just occurred for me.

The Automatic Bug Reporting Tool tried to report it, but the bug is "CLOSED WORKSFORME."

Obviously there is an issue.

Note You need to log in before you can comment on or make changes to this bug.