Bug 982882 - Console breaks if the only available framework cartridge is diy
Console breaks if the only available framework cartridge is diy
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 01:07 EDT by Miciah Dashiel Butler Masters
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-console-1.9.15-1, openshift-origin-console-1.5.20-2
Doc Type: Bug Fix
Doc Text:
Attempting to access the management console at https://broker.example.com/console/application_types before any web cartridges were installed displayed an error. With this fix, logic has been added to correctly handle this scenario. The management console now correctly reports the cartridges that are available.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:18:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Actual results (error) (45.94 KB, image/png)
2013-07-10 01:08 EDT, Miciah Dashiel Butler Masters
no flags Details
Expected results (no error) (96.54 KB, image/png)
2013-07-10 01:09 EDT, Miciah Dashiel Butler Masters
no flags Details

  None (edit)
Description Miciah Dashiel Butler Masters 2013-07-10 01:07:05 EDT
Description of problem:

When I install a new broker host and new node host and try to use the console, it does not work unless I install a framework cartridge besides the default diy or disable downloadable cartridges.


Version-Release number of selected component (if applicable):
Tested with latest packages.

How reproducible:
Thoroughly.


Steps to Reproduce:

1. Install a new broker host and a new node host.

I used the latest openshift.ks script from the enterprise-1.2 branch of the openshift-extras Github repo to install on RHEL63 VMs.

I installed the broker host with the following option: install_components=broker,named,activemq,datastore

I installed the node host with the following options: install_components=node broker_hostname=broker.example.com node_hostname=node01.example.com

And after installation, I added the DNS entry for the node:

    # oo-register-dns -h node01 -d example.com -n [redacted]

2. Load https://broker.example.com/console/application_types


Actual results:

I get "An error has occurred" (screenshot attached: console-application_types-error.png).


Expected results:

I should be presented with choices for creating a new application (screenshot attached: console-application_types-expected.png).


Additional info:
I have only the default cartridges installed:

    [root@node01 ~]# oo-cartridge-list
    Cartridges:
            cron-1.4
            diy-0.1
            haproxy-1.4

Workaround: If I install a framework cartridge such as openshift-origin-cartridge-php on the node host and clear the cache using `oo-admin-broker-cache -c --console` on the broker host, the problem goes away.

Workaround: If I edit /etc/openshift/broker.conf on the broker host to set DOWNLOAD_CARTRIDGES_ENABLED="false" and restart openshift-broker, the problem goes away.

Suggested fix: If I edit app/views/application_types/index.html.haml per pull request https://github.com/openshift/enterprise-server/pull/100 and restart openshift-console, the problem goes away.
Comment 1 Miciah Dashiel Butler Masters 2013-07-10 01:08:45 EDT
Created attachment 771386 [details]
Actual results (error)
Comment 2 Miciah Dashiel Butler Masters 2013-07-10 01:09:16 EDT
Created attachment 771387 [details]
Expected results (no error)
Comment 3 Miciah Dashiel Butler Masters 2013-07-10 01:15:30 EDT
Adding Clayton to the Cc list.

Clayton, does the fix look OK?  Also, I haven't checked whether it is possible to reproduce the bug on Origin, but does it look like Origin also needs this fix?
Comment 6 Clayton Coleman 2013-07-10 10:55:49 EDT
That's the correct fix and should be merged into master.
Comment 7 openshift-github-bot 2013-07-15 15:25:49 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/215962e03cc215b84d3dcc9fd2eb41b6772630ea
Console: Make sure excluded_tags is set

When listing the custom cartridge type (i.e., the diy cartridge), make
sure that excluded_tags in case it was not set earlier.  This commit
fixes bug 982882.
Comment 9 Gaoyun Pei 2013-07-18 02:14:26 EDT
Verify this bug on puddle: 1.2/2013-07-17.1

After setting up an OSE env with only cron-1.4/diy-0.1/haproxy-1.4 cartridge installed, check the application_type page on web console, it shows correctly as the Expected results.
Comment 11 errata-xmlrpc 2013-08-05 13:18:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.