Bug 982887 - euler.map not installed correctly
euler.map not installed correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
19
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 01:14 EDT by Peter Backes
Modified: 2013-11-10 03:01 EST (History)
6 users (show)

See Also:
Fixed In Version: texlive-2013-3.20131021_r31961.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 03:01:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing (1.25 KB, patch)
2013-09-13 19:42 EDT, Jason Tibbitts
no flags Details | Diff

  None (edit)
Description Peter Backes 2013-07-10 01:14:44 EDT
Description of problem:
diff -u  updmap.cfg.rpmsave updmap.cfg after recent upgrade
...
-Map      euler.map
+Map 
...


Version-Release number of selected component (if applicable):
texlive-amsfonts-svn29208.3.04-0.1.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1. upgrade to recent package version

Actual results:
crippled euler map entry

Expected results:
dull euler map entry

Additional info:
caused by additional spaces in postinstall and postuninstall scriptlets:

% rpm -q --scripts texlive-amsfonts-svn29208.3.04-0.1.fc19.noarch
postinstall scriptlet (using /bin/sh):
...
/usr/bin/updmap-sys --quiet --enable MixedMap=cyrillic.map > /dev/null 2>&1
/usr/bin/updmap-sys --quiet --enable Map=     euler.map > /dev/null 2>&1
                                         ^^^^^ here
...
postuninstall scriptlet (using /bin/sh):
...
/usr/bin/updmap-sys --disable MixedMap=cyrillic.map > /dev/null 2>&1
/usr/bin/updmap-sys --disable Map=     euler.map > /dev/null 2>&1
                                  ^^^^^ and here
...
Comment 1 Garrett Mitchener 2013-08-12 15:30:32 EDT
I see this too, please fix.


The error messages that come out of pdflatex are things like

kpathsea: Running mktexpk --mfmode .... eufm10
mktexpk: don't know how to create bitmap font for eufm10
mktexpk: perhaps eufm10 is missing from the map file.
...
!pdfTeX error: pdflatex (file eufm10): Fount eufm10 at <line number> not found
 ==> Fatal error occurred, no output PDF file produced!


The manual way to get the euler fonts working is to log in as root and run

updmap-sys --enable Map=euler.map
Comment 2 Jason Tibbitts 2013-09-13 19:12:02 EDT
This is biting my users as well now that I've pushed F19.  Let me see what I can come up with.
Comment 3 Jason Tibbitts 2013-09-13 19:42:39 EDT
Created attachment 797551 [details]
Patch fixing

Yeah, the fix is simply to remove the additional five spaces in those two points in the spec.
Comment 4 Jason Tibbitts 2013-10-10 21:38:45 EDT
A big texlive update was just committed and while it touches the very code involved in this problem it preserves the errant spaces.  I'm considering just committing the fix myself but this is one of those packages I'm really not sure I should ever touch.
Comment 5 Garrett Mitchener 2013-10-10 22:44:31 EDT
I say go for it.  You're just removing five bad spaces from two lines of the spec file...
Comment 6 Jason Tibbitts 2013-10-11 13:35:12 EDT
Looks like Jindrich did commit a fix for this a few hours ago.  Thanks!
Comment 7 Fedora Update System 2013-10-17 06:54:11 EDT
texlive-2013-1.20131014_r31898.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/texlive-2013-1.20131014_r31898.fc20
Comment 8 Fedora Update System 2013-10-17 06:56:59 EDT
texlive-2013-1.20131014_r31898.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/texlive-2013-1.20131014_r31898.fc19
Comment 9 Fedora Update System 2013-10-17 16:24:50 EDT
Package texlive-2013-1.20131014_r31898.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2013-1.20131014_r31898.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19153/texlive-2013-1.20131014_r31898.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-21 10:14:24 EDT
texlive-2013-2.20131019_r31948.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2013-2.20131019_r31948.fc18
Comment 11 Fedora Update System 2013-11-10 03:01:53 EST
texlive-2013-3.20131021_r31961.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.