Bug 982890 - Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents...
Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents...
Status: CLOSED DUPLICATE of bug 972881
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 01:31 EDT by joshua
Modified: 2013-07-12 07:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 07:02:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ausearch output (9.15 KB, text/plain)
2013-07-10 11:17 EDT, joshua
no flags Details

  None (edit)
Description joshua 2013-07-10 01:31:17 EDT
Description of problem:

text based login takes 20 to 30 seconds, and graphical login never really completes.  Here is why:


Jul 10 04:18:31 f19-laptop dbus-daemon[692]: dbus[692]: [system] Activating via systemd: service name='org.freedesktop.ConsoleKit' unit='console-ki
t-daemon.service'
Jul 10 04:18:31 f19-laptop dbus[692]: [system] Activating via systemd: service name='org.freedesktop.ConsoleKit' unit='console-kit-daemon.service'
Jul 10 04:18:31 f19-laptop systemd[1]: Starting Console Manager...
Jul 10 04:18:31 f19-laptop dbus-daemon[692]: dbus[692]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Jul 10 04:18:31 f19-laptop dbus[692]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Jul 10 04:18:31 f19-laptop console-kit-daemon[2426]: console-kit-daemon[2426]: WARNING: Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.95" (uid=0 pid=2380 comm="/bin/login --         ") interface="org.freedesktop.ConsoleKit.Manager" member="OpenSessionWithParameters" error name="(unset)" requested_reply="0" destination="org.freedesktop.ConsoleKit" (uid=0 pid=2426 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Jul 10 04:18:31 f19-laptop console-kit-daemon[2426]: console-kit-daemon[2426]: WARNING: Could not acquire name; bailing out
Jul 10 04:18:31 f19-laptop systemd[1]: Started Console Manager.
Jul 10 04:18:31 f19-laptop console-kit-daemon[2426]: WARNING: Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.95" (uid=0 pid=2380 comm="/bin/login --         ") interface="org.freedesktop.ConsoleKit.Manager" member="OpenSessionWithParameters" error name="(unset)" requested_reply="0" destination="org.freedesktop.ConsoleKit" (uid=0 pid=2426 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Jul 10 04:18:31 f19-laptop console-kit-daemon[2426]: WARNING: Could not acquire name; bailing out
Jul 10 04:18:31 f19-laptop systemd[1]: console-kit-daemon.service: main process exited, code=exited, status=1/FAILURE
Jul 10 04:18:31 f19-laptop systemd[1]: Unit console-kit-daemon.service entered failed state.
Jul 10 04:18:56 f19-laptop dbus-daemon[692]: dbus[692]: [system] Failed to activate service 'org.freedesktop.ConsoleKit': timed out
Jul 10 04:18:56 f19-laptop dbus[692]: [system] Failed to activate service 'org.freedesktop.ConsoleKit': timed out

I turn off selinux, and logins succeed instantly.



Version-Release number of selected component (if applicable):

$ rpm -qa kernel selinux\* Console\* | sort
ConsoleKit-0.4.5-5.fc19.x86_64
ConsoleKit-libs-0.4.5-5.fc19.x86_64
ConsoleKit-x11-0.4.5-5.fc19.x86_64
kernel-3.9.9-301.fc19.x86_64
selinux-policy-3.12.1-59.fc19.noarch
selinux-policy-devel-3.12.1-59.fc19.noarch
selinux-policy-targeted-3.12.1-59.fc19.noarch
Comment 1 Miroslav Grepl 2013-07-10 02:47:59 EDT
What does

# ausearch -m user_avc
Comment 2 joshua 2013-07-10 11:17:15 EDT
Created attachment 771697 [details]
ausearch output
Comment 3 Miroslav Grepl 2013-07-12 07:02:13 EDT
Please execute

# restorecon -R -v /usr/sbin

*** This bug has been marked as a duplicate of bug 972881 ***

Note You need to log in before you can comment on or make changes to this bug.