Bug 982915 - urlwatch: TypeError: Can't convert 'bytes' object to str implicitly
urlwatch: TypeError: Can't convert 'bytes' object to str implicitly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: urlwatch (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 02:37 EDT by Jan ONDREJ
Modified: 2014-07-19 02:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: urlwatch-1.16-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-19 02:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (634 bytes, patch)
2013-07-10 02:37 EDT, Jan ONDREJ
no flags Details | Diff

  None (edit)
Description Jan ONDREJ 2013-07-10 02:37:43 EDT
Created attachment 771415 [details]
fix

Description of problem:
After update to Fedora 19 urlwatch is using python3. I am not sure, if
this is my problem, but "URLs" with pipe can't be processed.

Version-Release number of selected component (if applicable):
urlwatch-1.15-4.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1. edit urls.txt
2. add "|cat /etc/hosts"
3. urlwatch

Actual results:
Traceback (most recent call last):
  File "/bin/urlwatch", line 333, in <module>
    timestamp_new))
  File "/usr/lib64/python3.3/difflib.py", line 1225, in unified_diff
    yield '+' + line
TypeError: Can't convert 'bytes' object to str implicitly

Additional info:
Patch which helped me is attached. Upstream (Thomas Perl) response to my patch:

>Thanks for the patch. I'll consider merging it once I migrate the whole urlwatch
>codebase to Python3-only.
>
>HTH :)
>Thomas

Looks like it will not be applied in short time, so please apply to Fedora package.
Comment 1 Fedora Update System 2014-07-10 03:42:50 EDT
urlwatch-1.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/urlwatch-1.16-2.fc19
Comment 2 Fedora Update System 2014-07-10 22:02:50 EDT
Package urlwatch-1.16-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing urlwatch-1.16-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8235/urlwatch-1.16-2.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2014-07-19 02:00:53 EDT
urlwatch-1.16-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.