Bug 982947 - /bin should be abolished
Summary: /bin should be abolished
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem   
(Show other bugs)
Version: 19
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-10 08:16 UTC by Ales Kozumplik
Modified: 2014-09-30 23:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 08:33:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ales Kozumplik 2013-07-10 08:16:04 UTC
Since all executable binaries and scripts that previously ended up in /bin are installed to /usr/bin now, and /bin is only a symlink provided by filesystem, we should roll out a plan to finish what UsrMove [1] has started and remove the last piece completely.

Besides being redundant it poses problems for packaging tools (bug 982664) and probably others.

[1] https://fedoraproject.org/wiki/Features/UsrMove

Comment 1 Ondrej Vasik 2013-07-10 08:33:09 UTC
I don't agree - problem is with shebangs - nobody wants to change #!/bin/bash to #!/usr/bin/bash ... actually, in my opinion, UsrMove feature just started and we are not in the position to do this. 
Closing Deferred, feel free to use this as tracker if you plan to file bugzilla against all components with scripts using shebang #!/bin/<whatever> , against all scripts using /bin/<whatever> direct construct... 
Long run, probably too long, given the response in less complicated things (e.g. for duplicate ownerships, it took ~2 years to close all tracked bugzillas except remaining 2).

Comment 2 Ondrej Vasik 2013-07-10 08:36:18 UTC
Or better - WONTFIX at the moment.

Comment 3 Ondrej Vasik 2013-07-10 08:36:48 UTC
(aaargh, need coffee, I meant CANTFIX)


Note You need to log in before you can comment on or make changes to this bug.