Bug 982950 - NPE when removing shareable disk
NPE when removing shareable disk
Status: CLOSED DUPLICATE of bug 982258
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
storage
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 04:19 EDT by Jakub Libosvar
Modified: 2016-02-10 13:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 04:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (5.13 MB, application/x-bzip)
2013-07-10 04:19 EDT, Jakub Libosvar
no flags Details

  None (edit)
Description Jakub Libosvar 2013-07-10 04:19:20 EDT
Created attachment 771451 [details]
logs

Description of problem:
SSIA

2013-07-10 10:55:28,198 - MainThread - plmanagement.error_fetcher - ERROR - Errors fetched from VDC(jenkins-vm-02.scl.lab.tlv.redhat.com): 2013-07-10 10:55:27,808 ERROR [org.ovirt.engine.core.bll.RemoveDiskCommand] (ajp-/127.0.0.1:8702-11) [347c0c66] Error during CanDoActionFailure.: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.RemoveDiskCommand.getSharedLocks(RemoveDiskCommand.java:360) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.buildLock(CommandBase.java:1556) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.acquireLockInternal(CommandBase.java:1517) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.acquireLock(CommandBase.java:1490) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.internalCanDoAction(CommandBase.java:680) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:311) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:348) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.RunAction(Backend.java:301) [bll.jar:]
	at sun.reflect.GeneratedMethodAccessor151.invoke(Unknown Source) [:1.7.0_09-icedtea]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_09-icedtea]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_09-icedtea]
	at org.jboss.as.ee.component.ManagedReferenceMethodInterceptorFactory$ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptorFactory.java:72) [jboss-as-ee.jar:7.2.0.Final-redhat-8]

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.6.master.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create shareable direct lun
2. Remove it
3.

Actual results:
NPE

Expected results:
direct lun removed

Additional info:
blocking direct lun test
Comment 1 Jakub Libosvar 2013-07-10 04:27:47 EDT
It's not related to direct lun. Happens with shared disk created on SD as well. Blocking other automation test suites (hotplug tests).
Comment 2 Jakub Libosvar 2013-07-10 04:28:57 EDT

*** This bug has been marked as a duplicate of bug 982258 ***

Note You need to log in before you can comment on or make changes to this bug.